WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Widget Context] The plugin does not work at all. (35 posts)

  1. findigart
    Member
    Posted 5 years ago #

    I liked the implementation - so clean and simple, so precise and concise.
    This defeats TS Custom Widget and MyCustomWidget by far.

    But...it simply does not work. Showing widgets cross-site does not work, "add to any" widgets do not show, Text widgets do not show in consistency with my instructions.

    What a shame, this could have been one Great plugin. I'd love to see improvements.

    http://wordpress.org/extend/plugins/widget-context/

  2. GimliGlider
    Member
    Posted 5 years ago #

    Confirmed. This doesn't work. I don't know how it got past WordPress's QA. Wasted time

  3. docuview
    Member
    Posted 5 years ago #

    I am using at most of my sites (dozens) at it works just fine, I really appreciate the filter and am happy that the latest release displays neatly (good work on CSS).

    Wonder what's going on with your versions?!

  4. findigart
    Member
    Posted 5 years ago #

    OK than, I an open to hear: How can you make it show a widget on all pages? Do you by any chance use add to any widgets? do they display? How can you show a widget only on the home page? (and yes I know it says to type in <home> or to choose 'homepage' but it simply does not work)...

    Thanks

  5. Kaspars
    Member
    Posted 5 years ago #

    If it doesn't work on your setup, please create a temporary login for me and send it to kaspars at konstruktors.com, and I will have a look.

  6. Kaspars
    Member
    Posted 5 years ago #

    findigart, to show widget on all pages you have to select "Hide on Selected" for widget context, and have nothing else selected.

    Previously this option was called "Display everywhere, except selected". Would that make more sense semantically?

  7. findigart
    Member
    Posted 5 years ago #

    Hello kaspars :-) Thanks for your reply...

    I have emailed you and included my response to your question there. If you wish you can publish it.

    Thanks :-)

  8. ScrltOTara
    Member
    Posted 5 years ago #

    How can I get the plugin to show on only one PAGE (not post). My permalinks use the page name as such:

    domain.com/pagename/

  9. findigart
    Member
    Posted 5 years ago #

    Maybe you can try:
    %parent-page%/%page-name%

    for example:
    articles/how-to-build-a-house

  10. Kaspars
    Member
    Posted 5 years ago #

    ScrltOTara, enter this:

    pagename

    in the URL target box. Add this:

    pagename/*

    if you also want to show that widget on all subpages.

  11. igc
    Member
    Posted 5 years ago #

    Is this possible? I have a script in Text-widget, I want script to be executed even if I use Hide function

    but, in actual whenever I use hide function in Widget Context It does hides but the script also disables - any workaround for this

  12. Kaspars
    Member
    Posted 4 years ago #

    igc, select 'Show on Selected' (with no other options selected) instead of 'Hide' and the script will run on every page.

    If don't want to have the widget title displayed, leave it empty.

  13. drinkonlyscotch
    Member
    Posted 4 years ago #

    The plug-in totally works, though it took me a few minutes to figure out what I was doing wrong. Basically, when you're adding/excluding certain pages, you simply enter the name of the page, with no slashes. The note beneath it pertaining to the use of slashes is only relevant when you're adding/excluding subpages.

    For example:
    If I want to have a widget only appear on the "Bicycles" page, I simply enter:

    bicycles

    But if I want the widget to appear on subpages of the "Bicycles" page, I enter:

    bicycles/*

    Hope that helps.

    Kaspars, great plug-in, but you could definitely improve the documentation. It's super easy to use, but it doesn't seem that way at first glance.

  14. jszei
    Member
    Posted 4 years ago #

    to expand on drinkonlyscotch's reply...
    To get it to work for single pages you must select the "Single Page" radio button on the left then in the "target by URL" box on the right put in your exact page permalink path. So, for example if you installed Atahualpa in the directory "blog" your path would be http://domainname/blog/pagename. Enter "blog/pagename" in the box. Or, if you want the widget to appear on all the pages under that page type "blog/pagename/*". Permalinks can be ugly so check the format of yours and make it "pretty" if you want it clean.

  15. airandseabattle
    Member
    Posted 4 years ago #

    Every time I try doesn't work :(

    http://s-curverecords.com/wordpress/artists/we-the-kings

    When I try and get the widget to ONLY show on this page, it shows on EVERY Artist page... I've use the following strings in the Target by URL field when on the Show on Selected w/ Single Page selected:

    artists/we-the-kings
    artists/we-the-kings/
    wordpress/artists/we-the-kings

    nothing seems to work... I'm using WP 2.8.3 - do you think that's the problem??

    If anyone has any ideas, suggestions or whatever feel free to email me at jason@papertigerllc.com

    Thanks!!!!

  16. findigart
    Member
    Posted 4 years ago #

    hello airandseabattle,

    Tick off "single page". "single page" is to show the widget on all pages in the website.
    artists/we-the-kings - what you wrote first should do the trick.

  17. thirty six
    Member
    Posted 4 years ago #

    I'm having problems with this too. I want a certain widget to display only on the home page. I've tried every variation I can think of without any good results. Here's a link with some screen shots.

    http://aardvarkmulti.com/rainbow/widget/

    I can't believe it's so difficult to get certain widgets to show up on only certain pages...maybe I should have gone with Joomla!?

  18. cancunforos
    Member
    Posted 4 years ago #

    Its a nice plugin but...

    I use Arthemia Premium Theme, i want to activate a widget that shows only on single posts, but if i select the option Show only on Single Post, the plugin just simple dont work, also when I use the "Hide on selected", select the HomePage but doesnt work.

    The plugin with other options work but shows the widget on all the pages of the site, with out filtering the options that i select.

    my site is:

    http://www.cancunforos.com
    I apreciate any help, excuse my english
    http://www.twitter.com/cancunforos

    Saul

  19. Gouri
    Member
    Posted 4 years ago #

    @ kasparsd
    Thank you so much!!
    I was facing problem in using Target by URL feature on my blog. I followed your suggestion to use 'pagename' in the box & its working fine. Really a great plugin. I'm loving it!!

  20. bmose14
    Member
    Posted 4 years ago #

    @kasparsd,
    I love your plugin, I used it and it worked perfectly with one site I built. Now I'm using the 'studiopress' template and I'm having problems. It is not that I am using the wrong syntax (I know that 'pagename/*' works from previous experience.
    I'm using wordpress 2.9.1. and I think it has something to do with the the adsense sidebar: file-name= adsense_sidebar336.php

    <!-- Insert your adsense code for a 336x280 rectangle right under here -->
    
    <a href="http://www.linked-site.com">
    	<img src="<?php bloginfo('template_directory'); ?>/images/my_ad.jpg" alt="ad"></img>
    </a>

    I have one widget set to display on the front page only, and that works fine. However if you go to a different page with the settings:
    Show on selected:
    Target URL: pagename/*

    It shows up on every page (except the first)
    any ideas? Thanks so much! I love your widget.

  21. bmose14
    Member
    Posted 4 years ago #

    Here is where adsense_sidebar336.php is being called in sidebar.php

    <div class="sidebarsB">
    	<ul>
    
    	<?php if ( !function_exists('dynamic_sidebar') || !dynamic_sidebar('sidebarsB') ) : ?>
    		<div class="adsense_sidebar">
    		<?php include (TEMPLATEPATH . '/adsense_sidebar336.php'); ?>
    		</div>
    	<?php endif; ?>
    	</ul>

    thanks!

  22. gerria
    Member
    Posted 4 years ago #

    I'm having the same type of issues.

    I want to the widget to only show on certain pages. Tried using all the suggested naming conventions. Still doesn't work.

    Works fine if I use "Single post" or "single page". Tried using a test page to use the "hide" function. That did not work either.

    Any ideas? This is the 3rd web site that I have used your plug-in, in and it's the first time it hasn't worked. I used Atahulpha for all the sites I've done.

  23. Kaspars
    Member
    Posted 4 years ago #

    bmose14, try specifying both:

    pagename
    pagename/*

    The first line will make it show up on that page, while the second one will make it show up on all the child pages.

  24. Kaspars
    Member
    Posted 4 years ago #

    gerria, it you're specifying URL's, you don't need to select any other options (either single page or single post).

    The only things that should be selected is either "Show on" or "Hide on".

  25. spencer@djsplicer.com
    Member
    Posted 4 years ago #

    I am having trouble with the widget as well. I must say, it's easier to use than Widget Logic or Widget Locationizer, but still a little frustrating. I've got it working perfectly on 2 pages when specifying the urls, but now I can't get it to work on another and I've tried every possible scenario I can think of. All my widgets from before activating the plugin display on all pages fine. But I'm trying to add another widget to all pages and it's not working for me.

    I mean, from what I've read, it should work if I don't select anything and say hide on selected. But I can't get it to even work now if I put the full url in. It's working on two pages, so I'm gonna leave those alone.. but what the hark is going on?

  26. Kaspars
    Member
    Posted 4 years ago #

    spencer, it would help a bit if you posted the URL of your site and general information on which widget you want to display/hide on which pages, as well as all the settings you have specified for those widgets.

  27. gerria
    Member
    Posted 4 years ago #

    Kasparsd, thanks for the response. I did use just the name ("target Url") and still did not work. The names of the pages have hyphens so I thought it had something to do with that. I created a test page called "test" and it still did not work.

    As I mentioned, it works fine when I'm choosing something on the the check box side and does not work when I don't have any checked and only have "Show" on and list a specified page.

    Have you heard of any other reasons why the plug-in may not be recognizing the page name?

    Thanks!

  28. vtriet
    Member
    Posted 4 years ago #

    just my 2-cents getting it to work:
    I had to change the permalink config to actually show the pagename in the URL before it would work. This Pagename (in the url) was NOT the name I've given the page, or maybe I changed the name somewhere along the way ... so don't get fooled, setup the permalink right, and check the URL to see that the actual pagename wordpress "thinks" it should be ;-) cheers !

  29. pictrix
    Member
    Posted 4 years ago #

    To show widget in a specific page you can try this:

    1. 1. Change permalink settings to something other than the default setting.
      • If you want to define the name of your page, first go to Pages>Edit>Quick Edit>Slug and name your page however you like. (Remember to use dashes between words, for example bicycle-news). Then, in Permalink Settings, select Custom Structure and type /%postname%.
    2. 2. In the Widget Context box, select Show on selected and in the section or target by URL type bicyles-news' to have the widget appear only on the "Bicycles News" page. As mentioned above, if you want to have the widget appear in the corresponding subpages, then typebicycle-news/*`

    After I did this I really liked this plug in. Thanks Kasparsd.

  30. pictrix
    Member
    Posted 4 years ago #

    Revision (with apologies):

    To show widget in a specific page you can try this:

    1. Change permalink settings to something other than the default setting.
      • If you want to define the name of your page, first go to Pages>Edit>Quick Edit>Slug and name your page however you like. (Remember to use dashes between words, for example bicycle-news). Then, in Permalink Settings, select Custom Structure and type /%postname%.
    2. In the Widget Context box, select Show on selected and in the section or target by URL type bicyles-news to have the widget appear only on the "Bicycles News" page. As mentioned above, if you want to have the widget appear in the corresponding subpages, then type bicycle-news/*.

    After I did this I really liked this plug in. Thanks Kasparsd.

Topic Closed

This topic has been closed to new replies.

About this Topic