WordPress.org

Ready to get started?Download WordPress

Forums

Widget Builder
[resolved] syntax error, unexpected T_FUNCTION on activation (7 posts)

  1. WingerSpeed
    Member
    Posted 1 year ago #

    Parse error: syntax error, unexpected T_FUNCTION in /wordpress-path/wp-content/plugins/widget-builder/classes/widget-builder.php on line 146

    Environment: php 5.2

    http://wordpress.org/extend/plugins/widget-builder/

  2. houstonjdd
    Member
    Posted 1 year ago #

    Same issue on our site after latest update to the plugin.

  3. diamoonwillow
    Member
    Posted 1 year ago #

    Also happened on my site after update

  4. Timothy Wood
    Member
    Plugin Author

    Posted 1 year ago #

    This comes from your site running PHP 5.2 - I am working on a fix to make this backward compatible to PHP 5.2 this weekend. In the meantime please revert to version 1.3. Let me know if http://downloads.wordpress.org/plugin/widget-builder.1.3.zip does not work for you and I can send you a copy of my local repo reverted to v1.3.

  5. Timothy Wood
    Member
    Plugin Author

    Posted 1 year ago #

    I have released version 1.5 this resolves issues with PHP 5.2 compatibility. You may download automatically from the .org repo or manually replace your installation with the download from http://downloads.wordpress.org/plugin/widget-builder.1.5.zip . Please let me know if you continue to have any issues.

  6. WingerSpeed
    Member
    Posted 1 year ago #

    @Timothy: V1.5 works. Thank you so much.

  7. Timothy Wood
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad this helped you out! If you don't mind selecting "Works" for your version of WP/Plugin in order to let folks know the support data.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.