WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Wickett Twitter Widget] "Error: Twitter Did Not Respond" (21 posts)

  1. chrishajer
    Member
    Posted 5 years ago #

    "Error: Twitter did not respond. Please wait a few minutes and refresh this page." I am having this issue with 2.8.2. It's been about 1/2 hour of that same message Going to the URL directly indicates that twitter is up and the id is correct. Any ideas?

    http://wordpress.org/extend/plugins/wickett-twitter-widget/

  2. chrishajer
    Member
    Posted 5 years ago #

    I wonder if it's related to caching? I was thinking "I wonder why the responses are not cached" so I looked through the code and found a couple references to wp_cache_get. That made me thing that caching IS being used, but maybe there's a conflict with WP Super Cache. I was using WP Super Cache 0.9.5 in full on mode. I turned it off and this error went away. I wonder if the error will return in 5 minutes 15 minutes or something, if there is an expiration on the cached data?

    This is working for me, right now, with WP Super Cache turned off.

    Also, WP_CACHE is true in wp-config.php

  3. chrishajer
    Member
    Posted 5 years ago #

    Today, with the WP Super Cache plugin off, it still occurs randomly.

  4. ryanwestfall
    Member
    Posted 4 years ago #

    I've been having the same problem all day. I've tried two or three other plugins as well, all with similar results. The funny thing is, on my other blog (also WordPress) my twitter plugin works fine, yet the same plugin won't work on my newest blog.

  5. pac10dave
    Member
    Posted 4 years ago #

    I thought mine was resolved because it was working fine for a little while, but it has been awful the last few days. Ryan, you say none of the other widgets are any better? This is frustrating...

  6. ElShaddai Edwards
    Member
    Posted 4 years ago #

    The only Twitter widget I've been able to get to work consistently over the past few days is "Twitter Widget", which says it uses the Javascript Twitter 'badge'. But then you're loading JavaScript on every page - and I'm only showing the Twitter feed on a home page. It'd be nice not to have the overhead when not needed.

  7. chrishajer
    Member
    Posted 4 years ago #

    You can use the Widget Logic plugin to show the Twitter badge on the home page only.

    http://wordpress.org/extend/plugins/widget-logic/

    But wait, is it the plugin that loads the JavaScript on each page? How do you make the badge appear on the home page only? Curious how you're doing this.

  8. pif
    Member
    Posted 4 years ago #

    Hello,

    I just installed this plugin and got this "twitter did not respond" error for a few hours now, nothing is changing.

    Anyone found how to display the last statuses easily ? It's amazing that there is still no reliable and easy Twitter widget so far. Also I need it to be multi-instance capable...

    Thank you very much for your help.

  9. ElShaddai Edwards
    Member
    Posted 4 years ago #

    @chrishajer: I am putting Twitter updates in a subsection of the footer area that is only shown on the home page. Since the overall subsection display is already being controlled by CSS, I don't need to have widget-level display control, e.g. Widget Logic.

    But as I mentioned above, the JavaScript would still load on every page - so I put a routine in my functions file to only load the JavaScript lines if the user was on the home page. Maybe Widget Logic would lead to same result, but I'm using a variety of custom page templates and have a lot of manual "widget" areas using hardcoded template tags and custom functions, so it was relatively trivial to handcode it. This is all in a child theme of the Thematic framework.

    Since none of the non-Javascript Twitter plugins have been working, I've actually just gone ahead and used Twitter's HTML/Javascript badge code right on the website - HTML in a text widget, JavaScript in the functions file. Not much control over the display elements, but at least it consistently works for my client.

  10. Alex Rodriguez
    Member
    Posted 4 years ago #

    I was getting the same errors at random but the biggest problem is that this widget added an extra 5 - 6 seconds to the load time of each one of my blog. Not sure why, but for now I am reverting back to Twitter Tools.

    Alex

  11. Suncokret
    Member
    Posted 4 years ago #

    This message is annoying as hell. I constantly get it and what's worse the author of this widget does not respond.

  12. seanduran
    Member
    Posted 4 years ago #

    Isn't this an official WP widget? Has ANYONE gotten this to work? Where do we contact support? It looks like this forum thread is useless in reaching the developers.

  13. Nick Momrik
    Member
    Posted 4 years ago #

    For those having problems, do you have WP_Cache enabled?

    http://codex.wordpress.org/Function_Reference/WP_Cache

    If not, can you try enabling it?

  14. seanduran
    Member
    Posted 4 years ago #

    Update: Thank you Nick

    I enabled WP_Cache and figured out that it was because I was accessing the page too often. It still happens, but only when I'm working on the site and refresh/access the page about 60 times within an hour.

  15. chrishajer
    Member
    Posted 4 years ago #

    I did have WP Super Cache and WP_CACHE was true in wp-config.php, initially when it happened to me. I've stopped using the plugin though so I cannot test it right now.

  16. Suncokret
    Member
    Posted 4 years ago #

    Yes I have WP_Cache enabled.... no use.

  17. brunosbille
    Member
    Posted 4 years ago #

    Hi i had the same problem...

    I've WP_Cache enabled

    And now it works thank you so much !

    Bruno
    http://brunosbille.com (Scrum and Agile in Belgium)

  18. tfo
    Member
    Posted 4 years ago #

    I have WP_CACHE enabled and still see the "Twitter did not respond error" frequently. Right now, I'm using WP 2.8.5 and Wickett 1.0.2.

  19. kunalashar
    Member
    Posted 4 years ago #

    I have WP_CACHE enabled and still see the "Twitter did not respond error" constantly - in fact, it hasn't worked for me at all.

    Right now, I'm using WP 2.9.1 and Wickett 1.0.2.

  20. cezzaa
    Member
    Posted 4 years ago #

    I've WP_Cache enabled. Thanks saglikgundemi.net

  21. leahingram
    Member
    Posted 4 years ago #

    Where would one fix the "cache"--in the code of the Twitter widget itself? If so, this is what mine says:

    if ( !$tweets = wp_cache_get( 'widget-twitter-' . $this->number , 'widget' ) ) {
    $twitter_json_url = clean_url( "http://twitter.com/statuses/user_timeline/$account.json", null, 'raw' );

    How would I fix to fix the problem? This start, fyi, when I upgraded to 2.9.1.

    Leah

Topic Closed

This topic has been closed to new replies.

About this Topic