WordPress.org

Ready to get started?Download WordPress

Forums

Welcome Pack
Plugin Not working (9 posts)

  1. ourfusion
    Member
    Posted 3 years ago #

    Hi Andy,
    I've contacted you before, I'm still having a problem with my installation, I now cannot get any version of your plugin to work properly... in my error log i'm getting this...

    [Fri Aug 13 16:21:27 2010] [error] [client xx.xx.xx.xx] PHP Warning: Invalid argument supplied for foreach() in /home/htdocs/wp-content/plugins/welcome-pack/welcome-pack.php on line 219, referer: https://fusion....org/wp-admin/options-general.php?page=welcome-pack&updated=true

    It used to be that 1.64 worked, but when I upgraded to 3.0.1, it is now broken. Any guidance is appreciated and thanks for taking the time.

    http://wordpress.org/extend/plugins/welcome-pack/

  2. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 3 years ago #

    Hi
    I'm not an Andy, but I am a Paul, and I did write Welcome Pack!

    I think I've seen this issue before but I've yet to been able to understand where the problem is in the code (though I haven't looked in a while). Is this giving an error on the "customise email" page on the dropdown list? Thanks

    Regards
    Paul Gibbs

  3. ourfusion
    Member
    Posted 3 years ago #

    O gosh, i'm so sorry Paul!

    I'm not getting any errors in the error log, which lead me to a thought... maybe it is working (and I'm an moron) but it works differently... I have a closed network, and only add people through the Super Admin > Users "Add New User" which the old plugin sent all of the emails, and friend requests, now it appears to only work if the user Activates the account... which the above way doesn't require.

    Is there any way to alter the plugin in a way that sends all of the emails, etc. if I simply add a new user from the admin panel?

    Thank you so much for your time in helping with this, and sorry for not understanding how it worked to begin with... if you have any thoughts on how i can achieve this, it would be much appreciated!

    mikey

  4. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 3 years ago #

    Mikey
    I'm fairly sure I had it it working for users added through wp-admin in some previous version, but I've just looked through the current code and I can't see anything. Like you say that must have been removed.

    The account activation emails themselves are provided by BuddyPress, so I'm not going to hook those up to be sent from the backend, if they aren't being sent akready. What I will do in the next version is make treat those signups as though they were already activated, which will start Welcome Pack.

    Unfortunately it's probably going to be next month before I have time to do this in light of my current priorities.

  5. ourfusion
    Member
    Posted 3 years ago #

    Awesome! Thanks so much Paul! I look forward to the next update, whenever it comes out.

    thank you so much for your time and responsiveness!
    mikey

  6. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 3 years ago #

    And thank you for the feedback :)

  7. sistak
    Member
    Posted 3 years ago #

    Hi Paul, I was so thrilled to find your awesome plug-in - great work!
    But my enthusiasm was short-lived as I discovered the above limitation while testing it. Since the thread is a few months old, may I ask whether you've had any spare time to look into this?

    I'm on WP 3.0.1 + BP 1.2.7
    Thanks Paul! Julie

  8. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 3 years ago #

    Hi Julie

    There will be a new welcome pack release in a few weeks when BP 1.3 is released, with this fix in :)

  9. sistak
    Member
    Posted 3 years ago #

    Great, thanks Paul - you just made my day :) Julie

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic