WordPress.org

Ready to get started?Download WordPress

Forums

Welcart e-Commerce
Paypal payment module (17 posts)

  1. Horkin
    Member
    Posted 4 years ago #

    Hi everybody.

    I'm trying to set up the paypal module.
    And unfortunately it doesn't work. :-(

    Few step to understand where I was wrong:

    module filename: paypal.php
    module path: /settlement/paypal.com

    module changes: I added my paypal sign in email and my ID merchant safe code.

    What I missed to do? Or where I was wrong?

    Thank you
    Horkin

  2. uscnanbu
    Member
    Plugin Author

    Posted 4 years ago #

    Hi

    You must set a module path in full directory-path.
    Make the field empty and try to update it. Then default full path is displayed.
    Please arrange it.

    Thanks

  3. Horkin
    Member
    Posted 4 years ago #

    First of all, thank you for your kind answer.
    But I think I didn't understand.

    I tried these two solutions:

    /var/www/vhosts/domainname.it/httpdocs/wp-content/settlement/paypal.php

    http://www.domainname.it/wp-content/settlement/paypal.php

    And in both case, the "checkout" was successfully without the activation of the module. I know that it's a my stupid mistake, but I'm not able to understand it :-((

    Thank you
    Horkin

  4. uscnanbu
    Member
    Plugin Author

    Posted 4 years ago #

    In the case of the URL, I think that you cannot choose PayPal by the process of the payment method. I also cannot understand it.

    Thanks

  5. teamakira
    Member
    Posted 4 years ago #

    Hello, Horkin.

    You might have the same problem I had.

    Go to system setting and put

    /var/www/vhosts/domainname.it/httpdocs/wp-content/settlement/

    to the place for settlement module path.

    Then go to general setting, for Payment module

    put paypal.php

  6. Horkin
    Member
    Posted 3 years ago #

    I just come back from my holidays and today i tried again.
    I don't know how... but I solved it :-) Maybe last time i made some misterious mistake that i avoid this time.
    Or maybe i just needed vacation :)
    Thank you to everybody that answered to this topic.

    Now I have another big trouble. The paypal payment page appears in ¥, japanese Yen. How can I change this default setting?

    Thank you.

    Horkin

  7. teamakira
    Member
    Posted 3 years ago #

    I'm a Japanese, but working on English ver.
    So, when I have a trouble, you have same trouble, too.

    Go to
    usc-e-shop/templates/cart/confirm.php

    and in 279's line.

    It is

    src="https://www.paypal.com/ja_JP/JP/i/btn/btn_buynowCC_LG.gif"

    Change that to

    src="https://www.paypal.com/en_US/i/btn/btn_buynowCC_LG.gif"

    It should work.

  8. Horkin
    Member
    Posted 3 years ago #

    Thank you for the answer, but maybe I was not able to explain my trouble correctly. I'm sorry. I already fixed that button :-)

    The real trouble is not the image of the payment button, but the default currency of the paypal-page after clicking that button.

    After click "buy now" it correctly redirects to paypal page, but the sum to pay is in japanese yen! And I need euros :-)

    Thank you again.

    Horkin

  9. Horkin
    Member
    Posted 3 years ago #

    Ok, I guess I solved it.

    In the same file (confirm.php) I changed "JP" and "JPY" with "EU" and "EUR". I don't know if I should do something else, but now it works.

    line 264 <input type="hidden" name="lc" value="EU">
    line 272 <input type="hidden" name="currency_code" value="EUR">

    Hope it could be helpful for someonelse.

    Horkin

  10. teamakira
    Member
    Posted 3 years ago #

    Oh. OK, whatever works.

  11. rumio
    Member
    Posted 3 years ago #

    Hi there.

    I have tried my best but I still cannot make paypal module to work. My testing URL is: http://mindbuilt.com/transitmoda-5/
    My settlement module path is: /home/mindbuil/public_html/transitmoda-5/wp-content/plugins/e-shop/settlement/

    I have already added paypal.php in general settings. Checkout is successful but the paypal module is not activated. I don't know what am I doing wrong? Any help is greatly appreciated.

  12. hitotch
    Member
    Posted 3 years ago #

    Rumio,
    Do you mean that Check out without the payment method works well, but only the paypal module does not work well?

    Anyway, it is not very safe to put your module under the plugins folder.
    Once you update the module, your module could disappear.

  13. rumio
    Member
    Posted 3 years ago #

    Hi Hitotch,

    Yes, the checkout works well but the paypal module does not get activated. I don't get to paypal website. When I click on Checkout button it just says "It has been sent successfully." Can you please have a look at it? I can send you the user id password details of the website.

    Thanks for the tip. I tried placing the module in another folder but it also didn't work.

  14. hitotch
    Member
    Posted 3 years ago #

    Rumio,

    Yes.
    Please give me the following information at first in your email.

    Are you using the PayPal test account?
    -> I need to test with some testing account.
    -> If not, please setup your testing account at first. We can work with it.

    You can email me "gmail.com" (same user name as here)

  15. rumio
    Member
    Posted 3 years ago #

    Hi Hitotch,

    Thanks for your reply. I have setup a test account on the server and sent you an email with all the details.

    I look forward to your reply.

  16. hitotch
    Member
    Posted 3 years ago #

    Rumio,

    Please read below.
    I found that "Type of payment" is not correct for Paypal in your system.

    (Ref. paypal_sample_en.php)
    -------------------------------------
    [Procedure 3] Add a new payment method in "Welcart admin panel / a General Setting page"
    * A payment method name: A payment method name displayed by a shop.(essential)
    * explanation : The explanation of a payment method displayed by a shop.
    * Type of payment: Choose "the representation supplier settlement".
    * Payment module: Fill it out with "paypal.php".
    * Push the button 'Add a new method for payment'.
    -------------------------------------

    And double check you have "paypal.php" on your server in the correct folder.

  17. rumio
    Member
    Posted 3 years ago #

    Hi Hitotch,

    Thank you very much for your reply. As you correctly mentioned my fault was that I was choosing the wrong option in "Type of Payment." I had to choose "the representation supplier settlement". Once I selected that I can see the paypal button appear.

    Your help just came in handy as I am doing the final deployment of the website within a week.

    Thank you very much.

    God bless you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags