WordPress.org

Ready to get started?Download WordPress

Forums

Web Ninja Google Analytics
[resolved] Edit posts page delay (6 posts)

  1. Jay Collier
    Member
    Posted 3 years ago #

    I love this plugin. It does everything I want, nothing more, nothing less.

    One question. My edit.php page loads more slowly now that there is the excellent graphic showing use of each post. Perhaps that is related to the time required to calculate or load those graphs?

    In any case, is there any way to turn off that function and find out? Also, would it be possible to cache that data?

    http://wordpress.org/extend/plugins/web-ninja-google-analytics/

  2. joshfowler
    Member
    Plugin Author

    Posted 3 years ago #

    Hello,

    Thanks for using my plugin. The delay isn't really the graph being loaded but more that it is trying to load the data from Google Analytics. That is the same reason why sometimes your Dashboard may run slow.

    It does cache some stats but not all since analytics is always changing. Although, I have thought about adding in a user selected time interval for refreshing cache. (e.g. You would be able to select if you want your stats to be refreshed by the minute, hour, or a few hours.) That would be in an update after the beginning of the year since I have another project I am about to release soon.

    As for your question on disabling the post stats you can do that as of version 1.0.5. As long as you have that version you can go to the "Post Admin Stats" option and there is a selection for "Disabled".

  3. Jay Collier
    Member
    Posted 3 years ago #

    Thank you for your quick response, suggestion, and future considerations!

  4. joshfowler
    Member
    Plugin Author

    Posted 3 years ago #

    Of course!

  5. Jay Collier
    Member
    Posted 3 years ago #

    Thought I'd let you know another situation for when the cache would be good. I just set up a new site (in 3.0.4 multisite) and imported about 1,000 posts from a WXR file. No Analytics account yet.

    Ninja Analytics is network activated, so the edit.php posts list was timing out every time.

    When I went to the NGA settings, I had to enter an Analytics account before I could select "Disabled" from the "Post Admin Stats" dropdown menu.

    So, I network deactivated and reactivated on a site-by-site basis, and I'm fine again.

    I thought I'd share in case anyone else experiences the slow load through network activation.

    Otherwise, this is definitely the best GA plugin available. Works great, especially for outbound.

    Thanks!

  6. Jay Collier
    Member
    Posted 3 years ago #

    Just wanted you to know this issue was really a problem as I was configuring a new site (within 3.04 multisite).

    "Post Admin Stats" doesn't appear until you've entered a GA account username and password. Unfortunately, my server timed out before the handshake could be completed.

    Perhaps the default can be disabled, and the "Post Admin Stats" drop-down could appear (but be inactivated until the GA account is linked) so it's clear where it will appear.

    My 2 cents.

    [A follow-up. Even though I selected "Disabled" under "Post Admin Stats", I'm still seeing the mini-charts on my edit-pages and edit-posts screens, and those are slowing load time. I'll check further ...]

    [Second updates: I clicked "Remove Account Info" and then reentered my GA information. Now working great! Perhaps some errant setting was causing the problem.]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic