WordPress.org

Ready to get started?Download WordPress

Forums

WassUp Real Time Analytics
[Plugin: WassUp] SPY function. Fatal error after 3.3 upgrade. (4 posts)

  1. popwireless
    Member
    Posted 2 years ago #

    Fatal error: Cannot use object of type WP_Error as array in /home/content/13/6065713/html/wp-content/plugins/wassup/lib/main.php on line 2065

    Part of the page starts to write then this happens. After this error appears the entire screen goes blank and the site begins a long, unending wait for http://www.apture.com or occasionally googleanalytics.com. I used to be a subscriber to apture's service but they discontinued it when google purchased them. I uninstalled their plugin.

    The raw data display also stopped working again. The last time this happened I think you suggested using another version of jquery. The pop-up box does not appear after the screen goes gray.

    The same situation exists across four blogs.

    http://wordpress.org/extend/plugins/wassup/

  2. popwireless
    Member
    Posted 2 years ago #

    I was able to get the error message by turning off the google map feature. With the feature on, the screen goes white after a few seconds waiting for apture.com.

  3. helened
    Member
    Plugin Contributor

    Posted 2 years ago #

    Thank you for reporting this. The problem lies with the new Google!Maps version 3, which is incompatible with WassUp 1.8.3. WassUp runs on Google!Maps v2 and requires an API key. To see Wassup-SPY map, you must sign up for the API key even though Google says you no longer need one.

    To sign up for a v2 API key, go to Wassup-Options >> "Spy Visitors Settings". Click the link for the Google!maps API key, then scroll to the bottom of the page to generate an API key for your website. Enter that key in WassUp-Options and you should be good to go.

    p.s: If you recently changed your domain name, you need a new API key for the new domain.

  4. kvestas
    Member
    Posted 2 years ago #

    As workaround you can change wassup plugin file (wp-content/plugins/wassup/lib/main.php) by adding extra error handling in 2065 line:

    if(!is_wp_error($api_remote)) {
    			if (!empty($api_remote['body'])) {
    				$apidata = $api_remote['body'];
    			} elseif (!empty($api_remote['response'])) {
    				$apidata = "no data";
    			}
    			$api_method='wp_remote_get';	//debug
    		} else {
    		// display error?
    		};

    I hope this could help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic