WordPress.org

Ready to get started?Download WordPress

Forums

Wapple Architect Mobile Plugin for WordPress
A Duplicate Content Nightmare (5 posts)

  1. Curtis4
    Member
    Posted 3 years ago #

    Google re-indexed every page as a mobile one. Even desktop users who click on the Google link are shown the mobile version. A major problem. Uninstalled.

    http://wordpress.org/extend/plugins/wapple-architect/

  2. mariostella
    Member
    Posted 3 years ago #

    OH MY! I was going to test this, I am outta here! Thanks for the heads up.

  3. lcarlos
    Member
    Posted 3 years ago #

    I haven't seen any of this.

    It's working perfectly for me.

    When i google my site using a desktop computer i see the results normally and i'm directed to the full content.

    And when i google on my old SonyEricsson k800i it shows my site on the same URLs and a small green icon next to the link telling that the site is mobile-friendly.

  4. Rebecca Markowitz
    Member
    Posted 3 years ago #

    When I do a search in google for a post title, the first search results is for the desktop version: example.com/post-name but the second result is for example.com/post-name?mobile=1 which is very upsetting. I'm not using a caching plugin. How can I remove the mobile links from appearing in desktop google searches?

  5. Nobble
    Member
    Posted 3 years ago #

    Make sure you're using canonical urls that point to the preferred version of the content - that's your pages way of saying what version should be indexed. Most SEO plugins let you change this easily. In addition to that you could disallow indexing of pages with the ?mobile=1 parameter, however, just getting the canonical url specified correctly should be sufficient in most cases. It can take a while before Google updates....best to also sign up for a google webmaster account and submit your sitemap.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic