WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Won't reactivate after upgrade (4 posts)

  1. marcmus
    Member
    Posted 4 years ago #

    I've been using W3 Total Cache happily for a few months now, and it's been amazing. A few days ago though, I upgraded to 2.9 and W3 Total Cache didn't reactivate with everything else. When I try to reactivate it it says "The Plugin Couldn't be activated because it triggered a fatal error /wp-content/uploads could not be created, please run following command:
    chmod 777 /wp-content"

    It was bizarre though, because wp-content/uploads already exists, and it existed before when W3 was working perfectly. I changed the permissions on wp-content, and wp-content/uploads but to no avail. I am still getting the fatal error and a message asking me to change my permissions.

    It worked fine on every other site I work on, and successfully passed the upgrade everywhere.

    Any help would be appreciated. Thanks,

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Sorry for the delay, the tag used here was not in my bookmarks.

    fatal error /wp-content/uploads could not be created, please run following command: chmod 777 /wp-content"

    Try removing: advanced-cache.php, w3tc/ and w3-total-cache-config.php (after backing it up so you can restore it later) and db.php from wp-content/. Then try doing: # chmod 777 wp-content/ wp-content/uploads/ before reactivating.

    If that fails, try setting the ownership and group for wp-content/ and wp-content/uploads/ to match the user:group combination of apache.

  3. ragulka
    Member
    Posted 4 years ago #

    Hi, I have the exact same problem. But it doesn't help to chmod or delete w3-total-cache-config.php (there are no other files or folders that you mentioned).

    /public_html/getahappylife.com/wp-content/uploads/ could not be created, please run following command:
    chmod 777 /public_html/getahappylife.com/wp-content

    But the folder /public_html/getahappylife.com/wp-content/uploads/ exists already and IS chmodded 777

    I am trying to run this on WordPress 3 beta 1. But I'm not sure that this is the case. This seems to be a problem for other versions as well.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    WordPress 3.0 is not supported yet. Do you have any errors in your error log?

Topic Closed

This topic has been closed to new replies.

About this Topic