WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] White page after activate minify HTML (16 posts)

  1. Hi,
    I have a problem with your plugin. All works fine until I activate the option for minify HTML. Then I get a blank page.
    Is there a log, where I can find an error message?
    I deactivate all plugins, but the error is still there.

    I use WPMU 2.8.4.

    Thx.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Posted 4 years ago #

    There's likely a parse error in the document somewhere. Try disabling minify options and see if the issue disappears, if not you will have to troubleshoot the issue with your document in order to fully minify it.

    The error log lives in: wp-content/w3tc/log/minify.log

  3. Hi, your log doesn't exist, but I create another log and I get this errors:

    [27-Oct-2009 14:46:46] PHP Fatal error:  Can't load Minify/HTML.php, open_basedir restriction. in ##/wp-content/plugins/w3-total-cache/lib/W3/Plugin/Minify.php on line 262
    [27-Oct-2009 14:46:46] PHP Fatal error:  Can't load Minify/CSS.php, open_basedir restriction. in ##/wp-content/plugins/w3-total-cache/lib/W3/Plugin/Minify.php on line 263

    Do you habv a solution for that?

  4. Frederick Townes
    Member
    Posted 4 years ago #

    There are PHP.ini issues that are causing files to not be properly installed/created/parsed. Try installing via FTP or sharing your PHP.ini settings. Unfortunately troubleshooting is quite difficult, especially with such limited information.

  5. Hi,

    I ask my webhoster and he couldn't find an error. So I replaced the lines with fix paths and now it works.

    Thx for your great plugin!

  6. Frederick Townes
    Member
    Posted 4 years ago #

    Great!

  7. gregma
    Member
    Posted 4 years ago #

    I have the same problem...
    "PHP Fatal error: Can't load Minify/HTML.php, open_basedir restriction."

    Maybe it's to late, but I don't understand the solution for it ;-)
    Can you give me one more hint?

  8. Frederick Townes
    Member
    Posted 4 years ago #

    So I replaced the lines with fix paths and now it works.

    @ocean90, what was your fix exactly?

  9. Hi,
    open /wp-content/plugins/w3-total-cache/lib/W3/Plugin/Minify.php.
    First I removed the line (~260) with set_include_path... and add the path of the DOCUMENT_ROOT to require_once:
    require_once ($_SERVER['DOCUMENT_ROOT'].'/wp-content/plugins/w3-total-cache/lib/Minify/Minify/HTML.php');

    But today I have looked over it again and now I have a solution which is more flexible:
    require_once (W3TC_LIB_MINIFY_DIR . '/Minify/HTML.php');
    The line with set_include_path... is here removed too.

    I hope it works for gregma too.

  10. gregma
    Member
    Posted 4 years ago #

    Works fine now!
    Thanks, ocean :-)

  11. a.verdeja
    Member
    Posted 4 years ago #

    It seems that I have the same problem. I have tried with ocean90 solution, but it doesn't function to me.

    Any ideas? My blog is in a subdirectory.

  12. @a.verdeja
    Do you replace all three lines? It should be:

    require_once (W3TC_LIB_MINIFY_DIR . '/Minify/HTML.php');
    require_once (W3TC_LIB_MINIFY_DIR . '/Minify/CSS.php');
    require_once (W3TC_LIB_MINIFY_DIR . '/JSMin.php');

    I get the error also in /wp-content/plugins/w3-total-cache/lib/W3/Cache/File.php on line 75

    The fix (line 75):
    if ((is_dir($path) ||
    Instead $dir you should use $path.

  13. masterbassie
    Member
    Posted 4 years ago #

    I'm suffering from the same issue in which it stems from minify. I see a blank page when i reload the main page after adding stylesheets to the css management section.

    specifically this is on my staging site which is on a different server. I tried loading the same files from my production server and it loads fine (of course it ends up being twice as many css files - from both servers). It seems that its not just the minification that is the problem but whatever stops the css files from loading is breaking my site

    any ideas?

  14. Frederick Townes
    Member
    Posted 4 years ago #

    Have you tried removing the CSS or JS files one at a time to see which one is not working out? Or checking the minify.log in in wp-content/w3tc/min/ ?

  15. masterbassie
    Member
    Posted 4 years ago #

    i'm also encountering some issues with permissions on the server, so i believe this may be a culprit. the minify.log does not exist in wp-content/w3tc/min/

    i tried removing one css file at a time but the error persists.

    possible reason is that i'm using my ip address for my server as the blog url - while it is in dev mode. i'm wondering if this is creating the file permissions errors?

  16. Frederick Townes
    Member
    Posted 4 years ago #

    If you're not using the same hostname in your options settings, then I doubt things will work properly.

Topic Closed

This topic has been closed to new replies.

About this Topic