WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Want to try Self-Hosted CDN on shared network | Problems (2 posts)

  1. Sama Web
    Member
    Posted 1 year ago #

    I use a shared server and of course get very slow page load time do to that fact. Pingdom suggests that I parralelize my domains in order to speed things up. A self-hosted cdn with w3tc seems like a good option for this, but I can't get it to work.

    When I enter what I'm pretty sure is the correct credentials, the following error appears:

    Error: Incorrect login or password (ftp_login(): Sorry, cleartext sessions are not accepted on this server.).

    When researching this with my host, it becomes apparent that my host does not allow ftp, but only sftp.

    When I try some variations in the credentials that should pull up sftp, I get the following responses:

    Error: Unable to connect to http://ftp.domain.org:22:21 (ftp_connect(): php_network_getaddresses: getaddrinfo failed: Name or service not known).

    These are the variations I have tried: http://ftp.domain.org:22, sftp.[domain].org, ftps.[domain].org, 127.0.0.1:22.

    The error is always the same and the :21 added at the end of the error gives me the hint that it is not able to recognize my request to use port 22, though I've seen in other posts that supposedly W3TC has this capability.

    Please help me figure out what I might be doing wrong. I have the feeling I can't convince my host to enable regular ftp for me, so I have to try here at the plugin level.

    Thanks

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, SFTP isn't currently supported as you noticed, it's planned for a future release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic