WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] w3totalcache and mailpress not working together (6 posts)

  1. blogophil
    Member
    Posted 2 years ago #

    Hi,

    I'me using w3totalcache v0.9.2.4 and the last version of mailpress 5.2.1 and it seems to be somme problem. If I deactivate w3totalcache mailpress works perfect.
    I've got a error log from mailpress with this message :

    PHP [E_NOTICE] 8 : MemcachePool::delete(): Server 127.0.0.1 (tcp 11211, udp 0) failed with: CLIENT_ERROR bad command line format.  Usage: delete <key> [noreply]
     (0) in /home/www/wp-scoffoni/wp-content/plugins/w3-total-cache/lib/W3/Cache/Memcached.php at line 111

    The subscription process to the newsletter is broken too, with an error when inserting data in mysql

    2012-01-10 21:01:44 000000 -- MAILPRESS [NOTICE] - Connected (MP_Mail)
    2012-01-10 21:01:44 000000 -- PHP [E_WARNING] 2 : mysql_real_escape_string(): 26 is not a valid MySQL-Link resource in /home/www/wp-scoffoni/wp-includes/wp-db.php at line 787
    2012-01-10 21:01:44 000000 -- MAILPRESS [ERROR] - *** Database error, Mail not saved :
    UPDATE <code>1845ap_mailpress_mails</code> SET <code>status</code> = '', <code>theme</code> = '', <code>themedir</code> = '', <code>template</code> = '', <code>fromemail</code> = '', <code>fromname</code> = '', <code>toemail</code> = '', <code>toname</code> = '', <code>charset</code> = '', <code>subject</code> = '', <code>html</code> = '', <code>plaintext</code> = '', <code>created</code> = '', <code>created_user_id</code> = 0, <code>sent</code> = '', <code>sent_user_id</code> = 0 WHERE <code>id</code> = 0
    2012-01-10 21:01:44 000000 --  **** End   logging **** mp_mail *** level : 8191 **** status : FALSE

    Any idea ?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. rashmani
    Member
    Posted 2 years ago #

    Hi there,

    it seems this issue affects multiple people/sites.
    Any update or workaround for it?

    Thanks,
    rash*

  3. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    1:

    PHP [E_NOTICE] 8 : MemcachePool::delete(): Server 127.0.0.1 (tcp 11211, udp 0) failed with: CLIENT_ERROR bad command line format.  Usage: delete <key> [noreply]
     (0) in /home/www/wp-scoffoni/wp-content/plugins/w3-total-cache/lib/W3/Cache/Memcached.php at line 111

    That's a PHP bug. See here: https://bugs.php.net/bug.php?id=58943

    2: Can you submit a bug submission from the support the plugin about?

    2012-01-10 21:01:44 000000 -- MAILPRESS [NOTICE] - Connected (MP_Mail)
    2012-01-10 21:01:44 000000 -- PHP [E_WARNING] 2 : mysql_real_escape_string(): 26 is not a valid MySQL-Link resource in /home/www/wp-scoffoni/wp-includes/wp-db.php at line 787
    2012-01-10 21:01:44 000000 -- MAILPRESS [ERROR] - *** Database error, Mail not saved :
    UPDATE <code>1845ap_mailpress_mails</code> SET <code>status</code> = '', <code>theme</code> = '', <code>themedir</code> = '', <code>template</code> = '', <code>fromemail</code> = '', <code>fromname</code> = '', <code>toemail</code> = '', <code>toname</code> = '', <code>charset</code> = '', <code>subject</code> = '', <code>html</code> = '', <code>plaintext</code> = '', <code>created</code> = '', <code>created_user_id</code> = 0, <code>sent</code> = '', <code>sent_user_id</code> = 0 WHERE <code>id</code> = 0
    2012-01-10 21:01:44 000000 --  **** End   logging **** mp_mail *** level : 8191 **** status : FALSE

    ?

  4. organicjar
    Member
    Posted 1 year ago #

    Any solution to this? I'm experiencing the same thing.

    Cheers!
    Jason

  5. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Can anyone submit a bug submission form from the support tab of the plugin if they're experiencing this?

  6. Manu-PB
    Member
    Posted 1 year ago #

    Hi,
    I have experienced the same problem since one month : posts were blocked "0 from n sent", and in the process_batch_send log the error message was :

    <b>Warning</b>: mysql_real_escape_string(): 25 is not a valid MySQL-Link resource in <b>/my_site/wp-includes/wp-db.php</b> on line <b>787</b>

    Yesterday I disabled W3 Total Cache and all posts have been released (also the oldest ones).

    I would be grateful if a solution could be found, in order to improve again the users' experience through reactivating W3 ...

    Regards,
    Manu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic