WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] w3tc minify issue (combined file not created) (7 posts)

  1. Rejo Zenger
    Member
    Posted 3 years ago #

    Problem: when enabling minify for CSS and Js files, the resulting combined and minified file is not created, and the visitor receives a 404.

    Configuration: WP 3.1.3, W3TC 0.9.2.2, Arras 1.5.0.1 with custom child theme. Full current configuration of W3TC can be found here:
    https://rejo.zenger.nl/tmp/w3-total-cache-config.txt

    On general tab, under Minify, I have set minify to be enabled, running auto mode, disk as cache method, the default html minifier, jsmin as Js minifier and CSS Tidy as CSS minifier. On the Minify tab, when I enable Js minify, the website breaks.

    The wp-content/w3tc/min/ directory contains:
    11a3e7e101d1e42535645207195f22c4.js.files
    11a3e7e101d1e42535645207195f22c4.js.id
    4dd9c65beec3a631e90022294006404d.js.files
    4dd9c65beec3a631e90022294006404d.js.id
    dcf059ae7a72a72c716a867b2c69b2de.js.files
    dcf059ae7a72a72c716a867b2c69b2de.js.id
    index.php
    .htaccess

    But it does not contain the file that is requested by the browser:
    https://rejo.zenger.nl/wp-content/w3tc/min/dcf059ae7a72a72c716a867b2c69b2de.1507494158.js

    The same happens for CSS files as well.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. moltar
    Member
    Posted 3 years ago #

    I've had that problem too. I think what needs to happen is that you need to enable rewrite rules to trigger the index.php file in the min/ directory to create those files. If you are using some fancy setup with nginx that bypasses that part, then you need to still trigger that index.php file.

  3. Rejo Zenger
    Member
    Posted 3 years ago #

    Problem solved: I did have some rewriting code that was in the way (site specific though, so this won't help anyone else). I have been able to specicy 7 Javascript files to be combined, the same goes for about 6 CSS files. I do see a Js error now though, but haven't had time to figure it out.

    I can't add any of the other four or five Js files. If I do it will break functionality.

  4. ronthai
    Member
    Posted 3 years ago #

    I got the same many js and css just can not get minified, it breaks the website.

    It still does break the website sometimes after making a small change. The only way to rectify it is delete all minified files and start all over again.

    A real pain in the ....

  5. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble.

  6. dmckinney5
    Member
    Posted 2 years ago #

    minify is not working for me when site to auto it breaks the site making it look like a sitemap also in the minify tab i try to use the help wizard and after i save settings then preview the site just shows as a blank white page so i do not deploy of course any help? thanks in advance

  7. scottdaris
    Member
    Posted 2 years ago #

    I don't know if this applies, but see my post about automatic minifying errors:
    http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify
    (btw, I meant to say *Important* parsing error found with automatic minify)
    In the minifying process, incorrect .js code was generated. You'll see what I mean in my post. Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic