WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3TC causing 404 on all WP posts? (7 posts)

  1. jcmilton
    Member
    Posted 4 years ago #

    I tried both the latest official version and the dev version. When I install W3TC and only use the default settings, my homepage shows up just fine, but if I try to go to a particular post I get 404. If I disable W3TC then the pages work again.

    What setting would most likely cause 404 errors?

  2. blau
    Member
    Posted 4 years ago #

    Use the development version and delete all caches, then check.

    If the issue continues, check the url rewriting option in w3tc.

  3. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    @blau seems correct, the WordPress .htaccess directives appear to be missing or erroneous.

  4. jcmilton
    Member
    Posted 4 years ago #

    OK I'm using the development version and I checked the URL Rewriting Option (under Minify) but I'm still getting 404 errors if I try to view a post.

    Any other ideas I could try?

  5. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    A bug submission form (submitted on the support tab of the plugin) with access to your server would be helpful at this point.

  6. jcmilton
    Member
    Posted 4 years ago #

    Thanks Frederick, I submitted a bug report. The support is appreciated.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Got it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic