WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] W3TC 0.9.2.3 - Occasional 404 errors for files (7 posts)

  1. Jan van Dank
    Member
    Posted 2 years ago #

    Since the 23.06.2011 (btw: please add the date to the release notes) I'm getting occasional 404 errors for zip files that are definitely on the server.

    Enabled options with default settings, except where noted:
    - Page cache -> Enhanced disk, cache 404
    - Minify -> Disk, line-break removal
    - Database -> Disk
    - CDN -> Self-hosted FTP on sub domain
    - Browser cache, no eTag

    The zip files causing errors are attached inn the WP media library but rejected for uploading to the CDN. The rule added to "Rejected files" is "/upload/*.zip" as the WP upload folder is here "example.com/upload/"

    This definitely happens since W3TC 0.9.2.3 - I never had this error before!
    I can provide more details regarding the settings or anything else if needed.

    This is a rather big problem for me... please help.

    Regards
    Jan

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Jan van Dank
    Member
    Posted 2 years ago #

    Quick update: It looks like disabling the CDN feature fixed this issue!
    So I guess it probably has to do with the exception of rejecting those zip files from the WordPress attachment directory ("Rejected files: /upload/*.zip").

    Anyone has an explanation for this?

  3. Jan van Dank
    Member
    Posted 2 years ago #

    Another update:

    Unfortunately this issue is not solved by disabling the CDN as I suggested in my previous post!

    Right now I'm having about 30% 404 errors and it started with 0.9.2.3 of W3 Total Cache. This is absurd...

  4. Jan van Dank
    Member
    Posted 2 years ago #

    I'm still investigating but I disabled "Minify" and set caching method to "Disc (Basic)" (from previously "Enhanced") and now it really seems to work.

    My question now is if it comes from Minify or the caching method. I'll post more information on this soon.

    Regards,
    Jan

  5. Jan van Dank
    Member
    Posted 2 years ago #

    After 1-2 days of testing I finally found out that the Disk caching method is not the problem... so there is only one solution: Something in the Minify code that changed from version 0.9.2.2 to 0.9.2.3 creates this extremly strange error!

    By the way, why am I talking to myself? This was quite a big problem to me and I really recommend you to fix it!

    Again, if you guys from W3 - Frederick Townes (?) - need more information, just ask here...

    Jan

  6. Jan van Dank
    Member
    Posted 2 years ago #

    Haha, well the problem still exists... for a few days it was gone* but now it's there as always**.

    Anyone experiencing something similar? By the way: I'm on Bluehost (Pro Package) if it helps...

    @W3TC team
    My offer is still valid! Just ask here if you need more information on solving this issue!

    *not really but significantly less
    **less but still 500 is still more then 0, right?

  7. Jan van Dank
    Member
    Posted 2 years ago #

    I'm not sure if my hosting company (Bluehost) changed something or it's the latest update of W3TC (when exactly was it updated?).

    Anyway, I checked it for 3 weeks and now it's really gone!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic