WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
w3 Total Cache not Caching (5 posts)

  1. webwalkerant
    Member
    Posted 2 years ago #

    Hi guys

    For some reason Total Cache does seem to be caching my pages.

    Each time I got to the home page, when I view source the Total Cache comment shows that it regenerated the page for this request.

    So I turned on debugging and this is what I am seeing:

    W3 Total Cache: Page cache debug info:
    Engine: disk: basic
    Cache key: w3tc_site.com_1_page_e251273eb74a8ee3f661a7af00915af1
    Caching: disabled
    Reject reason: Requested URI is rejected
    Status: not cached
    Creation Time: 0.634s
    Header info:
    X-Pingback: http://site.com/xmlrpc.php
    Content-Type: text/html; charset=UTF-8
    X-Powered-By: W3 Total Cache/0.9.2.4

    Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

    Minified using disk: basic
    Database Caching 6/6 queries in 0.011 seconds using disk: basic
    Object Caching 608/613 objects using disk: basic

    Served from: site.com @ 2011-09-18 17:47:24

    Any ideas what could be going on hear?

    Cheers

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. webwalkerant
    Member
    Posted 2 years ago #

    Anyone got any idea on this one? Its really killing me at the moment.

  3. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    What is the URL that is not caching or is this always true?

  4. webwalkerant
    Member
    Posted 2 years ago #

    Thanks very much for the reply.

    Here is the site in question htt p:// ter rybe ren son .co m (just take out the spaces)

    I get it as being outright disabled on the home page. I'm wondering if it has to do with the trailing slash issue that people have been talking about... Is this the case?

    The other pages on the site appear to be working correctly but if you navigate around (using 2 different browsers so to have different local caches) you will start to see strange results. For instance the portfolios page might randomly take 4 seconds to get a 304 response from the server.

    Lastly, even though I have Preloading enabled (at 900sec, batch 10 and my Garbage collection interval is 3600sec) I still go to the site and am experiencing the page being loaded for the first time. I would have thought the Preloading would eliminate this. What can I do to eliminate this?

    Any thoughts on these would be greatly appreciated.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    That sounds like typical shared hosting issues. Who's your host?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic