WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
W3 total cache -just installed now site not showing correctly (13 posts)

  1. HypnosisDerby
    Member
    Posted 3 years ago #

    Hi
    In installed w3tc andf followed the instructions accroding to the walkthrough on wpbeginner.com. It worked great increasing page speed score from 77 to 97!

    Now though my site looks like this : http://stopsmokingderbys.co.uk/ ??

    I have not enabled the cdn,as im not sure if to or not, the compatibility check shows:
    - php timezone not set,
    - Opcode cache: Not installed
    - Memcache extension: Not installed

    Any advice what i should do?

    thanks
    ps i am a noob so bear it in mind : ) when replying.

  2. HypnosisDerby
    Member
    Posted 3 years ago #

    ps

    all ive done since install is update some posts- i manually entered all the seo data as it said to in wpbeginner.com

  3. kfawcett
    Member
    Posted 3 years ago #

    It looks like your CSS and JS files are corrupt. Are you minifying them? If so try turning off minify and see if that fixes your issue. Then try minifying one at a time and see which of them break.

  4. HypnosisDerby
    Member
    Posted 3 years ago #

    that looks ok now, ill try it again later. Ill check the page speed again now

    thanks

  5. HypnosisDerby
    Member
    Posted 3 years ago #

    Hi

    The page speed is down to 75 again now :@ If they are corrupt how come, cant i reinstall them?

    thanks

  6. kfawcett
    Member
    Posted 3 years ago #

    I'm not saying your files are corrupt, but something happened when you minified them. You'll need to investigate how or why it's happening.

    So try to minify one file, or set, at a time. I would maybe start with minifying all of your CSS files. See if the site works and then add all of your JS files. If something breaks with the JS files, then only do one at a time until your figure out which one or ones are causing the problem.

    In addition I would turn off HTML minify settings until you have investigated your JS and CSS files.

    Remember to clear your caches after each time you save the settings.

  7. kfawcett
    Member
    Posted 3 years ago #

    Also check your HTML code. I see this below, which could be causing some problems. I would remove that <style type="text/css"> </style> since there is nothing in there expect some weird body{}. Which could be cuasing some problems.

    <style type="text/css"> 
    
    	body{}
    </style>
  8. HypnosisDerby
    Member
    Posted 3 years ago #

    Hi

    Ive found out which one was causing the issue: wp-content/themes/iblogpro/style.css

    so i uncheck the box apply and close then when i check the help wizard again the box has checked itself? it does it everytime i try this. If possible id like to just uncheck the trouble causer and check all the others to increase my page load speed

    Ive not deleted the html yet until ive done this?

  9. kfawcett
    Member
    Posted 3 years ago #

    The help wizard only shows you what files you might want to add. It doesn't automatically add them for you. The files that have been added are on the Minify Settings page below the Help wizard button. In the JS and CSS sections.

    Find the file, in your case the iblogpro style.css and click delete beside it under the CSS minify settings -- if it's there.

  10. HypnosisDerby
    Member
    Posted 3 years ago #

    ive done that but now my feature slide is not working and i reckon other things might not work properly either.

    Its a great plug in if i can get by these issues? I know page speed isnt everything but it all adds up

    thanks again

  11. kfawcett
    Member
    Posted 3 years ago #

    It's not the plugin that is causing the problem. It's most likely due to bad coding practices or putting files in the wrong area (i.e. JS in the head or below body).

    Are you minifying all of your JS files? See if one of those is causing the problem with your feature slide not working correctly. Are you trying to use all the features of minify? Like space removal and comment removal? If so try to minify your files without those settings first and see if that helps. Sometimes remoing spaces can cause your files to break if they are not written properly.

    If you find the file in question. Ask the developer of the plugin to take a look at it.

  12. HypnosisDerby
    Member
    Posted 3 years ago #

    Hi

    The guy who designed the template just told me not to minify the JS or CSS
    and yes that was what was making the feature not work- you can tell im a noob!!

    So ill see what he says and may need to look for other ways to speed the site up : (

    That speed of 97 was damn good

    Thanks for your help, i do appreciate it

    Garry

  13. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Glad it worked out. Great job @kfawcett!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic