WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
User Agent Groups not working consistently (2 posts)

  1. toyNN
    Member
    Posted 2 years ago #

    re: W3TC 0.9.2.4, WP 3.2.1

    I'm trying to use the W3TC User Agent Groups and the predefined "high" group and set the theme to "pass-through" so that mobile users will get a cached pages specifically for them and I'm finding its only partly working or I've not configured it correctly.

    As I have it now when a mobile user hits the site:

    - if no cached page exists then "_index_high.html" is created and served.
    - if "_index_high.html" is the only cached page they correctly get it.
    - if "_index.html" (for non-mobile users) already exists then "_index_high.html" isn't created and the mobile user in the "high" group is incorrectly served the "_index.html" page.
    - if both "_index_high.html" and "_index.html" exist - the mobile user incorrectly gets "_index.html".

    As far as I can tell W3TC should allow for the two cached pages within the same URI. Its puzzling why the mobile user gets the incorrect cached page.

    Perhaps I'm not understanding how User Agent Groups can be used to consistently serve up alternate cached pages.

    Any help or ways to tbshoot this further appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    What are your page cache settings?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic