WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Upload path incorrect (5 posts)

  1. Mike Davis
    Member
    Posted 3 years ago #

    Hello,

    I am using the current version of W3 Total Cache with WordPress 2.9.2 and just noticed the following error in a big red box at top of the "Performance" section of my wp-admin panel on all four of the blogs I am running this plugin on:

    The path found in the database (wp-content/uploads) is inconsistent with the current paths found on your server. Please manually adjust the upload path either in miscellaneous settings or in the site's edit page if in network mode.

    In a previous thread Frederick stated that this is possibly due to changing servers. However, I have not changed my server in about a year and a half and I just started using W3 Total Cache a little bit ago.

    The path of "wp-content/uploads" is correct, except WordPress puts the uploads into date-specific folders.

    Any ideas what is going on here and how to get rid of this error notice?

    Thanks!

  2. obliviousinvestor
    Member
    Posted 3 years ago #

    I'm in a similar situation--currently getting each of the following messages:

    "Your store uploads folder is not available. Default WordPress directories will be created: /var/www/vhosts/obliviousinvestor.com/httpdocs/wp-content/uploads."

    and

    "The path found in the database (/var/www/vhosts/obliviousinvestor.com/httpdocs/wp-content/uploads) is inconsistent with the current paths found on your server. Please manually adjust the upload path either in miscellaneous settings or in the site's edit page if in network mode."

    I'm not sure where "miscellaneous settings" is or what I'm supposed to adjust the upload path to. (Is it currently set to the above path and that's the wrong one? Or that's the right path that I'm supposed to set it to?)

    In WP's Media Settings, there's a field for "Store uploads in this folder," but if I copy/paste the above path into that field, I still get the same error.

    Like the above user, I haven't switched servers in a long time. I just started getting this error message today when I installed a plugin.

    Anyone with ideas/suggestions would be appreciated. :)

  3. Mike Davis
    Member
    Posted 3 years ago #

    Any news on this? Thanks!

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Are you using multisite? Doesn't seem so, so you need to look for Misc' Settings in your settings list and update the uploads path.

  5. Mike Davis
    Member
    Posted 3 years ago #

    The issue seemed to be with the version of WordPress I was using. I just upgraded from 2.9.2 to the current 3.0.4 and the warning is gone. The upload path was OK, so I guess W3 Total Cache didn't like my version of WordPress.

    All seems to be good now running WordPress 3.0.4.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic