WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Stop RSS feed from being served through CDN (4 posts)

  1. Parneix
    Member
    Posted 2 years ago #

    Hi,

    With the help of W3 Total Cache, I setup a CDN (Amazon’s CloudFront). Which works just great.

    I noticed though that even my RSS feed is being fed its images by the CDN. Meaning that when I publish a new post with an image, the copy distributed through my RSS feed gets its image from the CDN, not from the origin server. Is there a way to make the RSS feed get the images from the origin server instead of the CDN?

    Thanks!

    P.

  2. Frederick Townes
    Member
    Posted 2 years ago #

    No there isn't. Why would you want to do that?

  3. alexwoolfson
    Member
    Posted 1 year ago #

    I've just encountered one reason you might want to be able to do that.

    I use MaxCDN with HTTP Referral Protection which only allows specific, whitelisted URLs to display images from my CDN. Overall this works great, but I've found that there is an unfortunate side effect. A lot of my readers follow my RSS feed updates via email and so, because of the HTTP Referral Protection, none of my images show up for them in the emails. If I was able to specifically tell W3 Total Cache not to replace images in my feeds with the CDN address but instead use the origin server image addresses, I'd be able to keep the HTTP Referral Protection. As it is, it looks like I'm going to have to disable the protection so that my feed email subscribers will be able to see the feed images.

  4. vtrs
    Member
    Posted 1 year ago #

    I agree with alexwoolfson. I have the same problem here

Topic Closed

This topic has been closed to new replies.

About this Topic