WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Setting certain options generate blank pages (8 posts)

  1. Luciano Passuello
    Member
    Posted 3 years ago #

    I just upgraded to 0.9.1 and now one of my pages is coming as blank.

    Playing with the settings, disabling HTML Minify fixes it. Curiously, if I close comments in the post, minify then works fine again.

    I was ready to declare this a Minify problem, but then I tried to enable the Debug options for the page, and that causes the blank page problem again (even with minify disabled).

    Unfortunately, my w3tc/log folder is also empty, so maybe I should take care of that problem first (but then I don't know where to start). I've set full permissions in the folder, but still have no log files in there.

    For reference, the problematic page is:
    http://belezaesaude.dae.com.br/minoxidil/
    (I have minify and debug disabled now for the page to work).

    (all other pages on site appear to be working well, regardless of W3TC options)

    Any help is appreciated!

    ==
    Here's my compatibility test results, for reference:

    PHP Version: 5.2.13
    PHP Timezone: Not set
    Web Server: Lite Speed
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: Not installed (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected
    WordPress Resources
    /home/lalala/public_html/.domains/belezaesaude.dae.com.br/wp-content: Write-able
    /home/lalala/public_html/.domains/belezaesaude.dae.com.br/.htaccess Write-able

    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

  2. Luciano Passuello
    Member
    Posted 3 years ago #

    Just a little more info:

    - I'm only minifying HTML, not CSS or JS.
    - This is the heaviest page on the page, with more than 3000 comments (they're in 50-comment pages, though).

    As I mentioned before, any piece of information that may help me (either on the blank page issue or on why the log files are not being generated) is very appreciated!

  3. Luciano Passuello
    Member
    Posted 3 years ago #

    After a lot of testing, I can say that most of what I mentioned above were red herrings. Here's the updated info:

    After a while (I believe it's 1h, the garbage collection time), that particular page (http://belezaesaude.dae.com.br/minoxidil/) starts being served as blank. It seems, then, that the problem is when the cached page gets replaced for the first time.

    What's most strange is that it happens even I add the page in the list of pages not to cache (which is being respected, since I see "(request URI is rejected)" in the page's source code).

    It seems the only way to make the problem go away is to disable the plugin as a whole (via the "Deselect this option to disable all caching functionality." checkbox).

    I have no idea where to start looking for the solution, as I don't have debug info or log files to check.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

  5. Luciano Passuello
    Member
    Posted 3 years ago #

    Thanks Frederick.

    The issue persists (which forced me to fully disable the plugin), but I agree I need to find a way to have the logs first, otherwise this is close-to-impossible to troubleshoot.

    Thanks again!

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    No problem, let me know if you're willing to let me debug on your site.

  7. Luciano Passuello
    Member
    Posted 3 years ago #

    Thanks Frederick. I was about to set up the server for you to debug, when it occurred to me to try a memory change in wp-config. It worked:

    I changed from:
    define('WP_MEMORY_LIMIT', '64M');

    to

    define('WP_MEMORY_LIMIT', '128M');

    I guess that's the price we pay for posts with 4,000 comments!

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Indeed. You can reduce memory usage by using a comments plugin like IntenseDebate by the way.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic