WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Ruined my .htaccess (8 posts)

  1. tenbandits
    Member
    Posted 1 year ago #

    The plugin ruined my .htaccess file irreparably, stopping me from gaining any access to either the front or back end of WordPress. In the end I had to scrub the entire thing and reinstall.

    Definite fail.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Stergos
    Member
    Posted 1 year ago #

    Still no answer? Only the two of us have this issue?

  3. Anthony Somerset
    Member
    Posted 1 year ago #

    i've only ever see this fail if the htaccess file was messed up in the first place and was missing things like the #BEGIN WORDPRESS headers etc and other rules mixed in.

    rule of thumb if you've ever got more than the default stuff going on in your htaccess file, is to back it up first and if worse comes to worse, manually install the htaccess rules in the file, the manual rules can be found on the install page of the plugin

    how did your file get hosed? was it totally cleaned or what?

  4. Stergos
    Member
    Posted 1 year ago #

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    This is my .htaccess file. I use more than 2 RewriteRules I just make it short. I guess the problem is "<IfModule mod_rewrite.c>" is present twice. Any ideas how this code should be?

  5. Stergos
    Member
    Posted 1 year ago #

    Yeap that's it!

    tenbandits maybe you have the same issue I had!

    open your .htaccess, if you have "<IfModule mod_rewrite.c>" twice copy your "RewriteRules" and paste them under the "RewriteBase /":

    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /

  6. Stergos
    Member
    Posted 1 year ago #

    Nope..... that was helpful only to access to homepage. when i attempt to surf on the site i get an error "It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration."

    Fix: Go to the settings of W3 Total Cache settings. In the “Page Cache” Section there would be an option of “Page Cache Method” and a drop-down next to it. Choose “Disk:Basic” in the dropdown.

  7. myziu1he
    Member
    Posted 1 year ago #

    I'm having the same issue - I can't access the front-end or back-end of the site I'm working on after I installed the update for this plugin. The page is white.

    (familiesgotravel.com)

    I'm not super familiar with how to work with .htaccess... how do I fix this problem? I can't even find the .htaccess in the files.

    This is a major fail :(

  8. Stergos
    Member
    Posted 1 year ago #

    myziu1he, try to do the fix I posted before maybe this solve your issue. You did not need to edit any file on this fix just the settings of this plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic