WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Replace Deafult Hostname With CDN but I don't use one? (13 posts)

  1. markey101101
    Member
    Posted 3 years ago #

    I tried and tried to activate W3 total cahce without CDN hostname as I don't use one but it keeps erroring that I must enter a CDN hostname. What can I do to fix this?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Seems you enabled CDN, but didn't mean to. Disable it on the general settings tab of the plugin.

  3. markey101101
    Member
    Posted 3 years ago #

    I have tried uncheckin the CDN checkbox and saving then trying to reactivate the caching though every time I do this it still keeps the CDN box checked and fires out the error telling me I need a hostname for the CDN.

    It just seems to be ignoring the fact that I have unchecked the CDN box.

  4. MTPrower
    Member
    Posted 3 years ago #

    I have this exact same problem. If I uncheck "enable CDN", it unchecks "deselect this option to disable all caching functionality" automatically. If I check "deselect this option to disable all caching functionality", it checks "enable CDN". It doesn't even wait for me to save the page. W3 Total Cache is broken!

  5. kay9
    Member
    Posted 3 years ago #

    I have the same exact problem as the poster immediately above (MTPrower).

  6. Forboding Angel
    Member
    Posted 3 years ago #

    Same problem here.

    Also, could

    deselect this option to disable all caching functionality

    Be any more bass ackwards?

    Why not change it to:

    Select this option to enable caching

    ^^^ MUCH BETTER!

  7. 72strokes
    Member
    Posted 3 years ago #

    That box doesn't have to be checked for caching to work. It's just an easy way to turn everything on or off at once.

  8. 72strokes
    Member
    Posted 3 years ago #

    That box doesn't have to be checked for caching to work. It's just an easy way to turn everything on or off at once.

    In the development version it's been changed to "Toggle all caching types on or off at once"

  9. Forboding Angel
    Member
    Posted 3 years ago #

    Then that box makes no sense whatsoever and should be removed entirely or it should have a better descriptor on it.

    What the box says is that if it isn't checked then caching won't work, and what you're telling me is that regardless of whether or not it is checked, caching will work...

    lolwut?

    Why does it exist in the first place then?

  10. Forboding Angel
    Member
    Posted 3 years ago #

    Ack you ninja edited me. Ok but the second half of my above post still applies.

  11. MTPrower
    Member
    Posted 3 years ago #

    From another post I received the replies:

    kfawcett wrote:

    Ignore the checkbox by "disable all caching funtionality" from my understanding it doesn't work anyways.
    I'm not running a CDN and W3TC works perfectly fine on my site.

    wjdennen wrote:

    The wording of that check box is very confusing. "deselect this option to disable all caching functionality"
    it's basically a toggle for the items below it. I think kfawcett is right, you can ignore it and just enable the parts you want (below).

  12. markey101101
    Member
    Posted 3 years ago #

    Did anyone ever find the fix for this?

  13. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    There are a number of topics being discussed here. A hostname is required in order for CDN functionality work properly. A CNAME is not necessary.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic