WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Remove query string from static content (5 posts)

  1. Julian Fernandes
    Member
    Posted 3 years ago #

    Hello!
    I was just wondering... how do i remove the query string from static content?
    Like minifying does this: "domain/wp-content/w3tc/min/index.php?file=ce797114.de174c.css"... it use "get". If i use rewrite url, it don't work (using eAccelerator).

    Now... when i change to disk, if i use rewrite url it looks like this "domain/wp-content/w3tc/min/index.php?file=ce797114.de174c.css?random numbers".

    How can i get it to not use "?" in any way?
    Using dev version btw, with LiteSpeed server.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Julian Fernandes
    Member
    Posted 2 years ago #

    bump

  3. bluejpro
    Member
    Posted 2 years ago #

    THanks for asking @Hitoriix I am wondering the same thing. Pingdom recommends caching with out query strings but this appears to be the approach used for disk caching by w3c total cache

  4. cyonite
    Member
    Posted 2 years ago #

    If you use Minify Auto it uses query strings as well. If you use manual it makes a single static file without query strings.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Uncheck the "Prevent caching of objects after settings change" option on the browser cache settings tab.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic