WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Recently an error occurred while creating the CSS / JS minify cache (30 posts)

  1. polle001
    Member
    Posted 3 years ago #

    Recently an error occurred while creating the CSS / JS minify cache: Some files were unavailable, please check the settings to ensure the site is working as intended.

    Is there a way to know which of the 60 files are unavailable ?

    Thanks.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    If you enable debug mode you can check the minify error log in wp-content/w3tc/min/min.log. Admittedly this feature sometimes gives false positives.

  3. Graham Stoney
    Member
    Posted 3 years ago #

    It sure would be awesome if the email notification mentioned which file had the failure. Just saying "an error occurred" is a little bit microsoft. ;)

    Thanks for the great plugin, by the way!

  4. Graham Stoney
    Member
    Posted 3 years ago #

    PS: I think the log file is wp-content/w3tc/log/minify.log

    PPS: Another awesome feature would be an option to automatically flush the caches whenever any setting changed.

    PPPS: Did I say thanks, again?

  5. waynejohn
    Member
    Posted 3 years ago #

    I'm seeing the same, and I agree with the idea that the email could contain a bit more info.

    If it never does though, I'd still use this plugin. It's the best one I've found and still works terrifically. Awesome job!!! Thanks!!!

    Cheers!

    Wayne

  6. John Saddington
    Member
    Posted 3 years ago #

    still having it mis-fire a notice. anyone else?

  7. Andrey "Rarst" Savchenko
    Member
    Posted 3 years ago #

    I started to get this error repeatedly with latest plugin version. It keeps coming up even after I disabled minify for CSS and JS.

    Log entries after enabling debug mode:

    [Sun, 03 Jul 2011 01:19:35 +0000] [/wp-content/w3tc/min/dc2bc0/post.include-footer.4248003223.js] [-] A group configuration for "include-footer" was not set
    [Sun, 03 Jul 2011 06:44:57 +0000] [/wp-content/w3tc/min/dc2bc0/default.include.61659561.css] [-] A group configuration for "include" was not set
  8. Everton
    Member
    Posted 3 years ago #

    Thanks for the info about the log files - hopefully I can stop my hourly emails!

    Frederick - you should add the location of the log files to the FAQ, as I imagine other users didn't know they existed.

  9. jessicareeder
    Member
    Posted 3 years ago #

    I'm receiving a similar error message. My CSS and JS are not being minified.

    Debug mode outputs these log entries:

    [Tue, 05 Jul 2011 02:49:15 +0000] [/wp-content/w3tc/min/72b8dd/default.include-nb.132243207.js] [http://loveandtrash.com/] A group configuration for "include-nb" was not set
    [Tue, 05 Jul 2011 02:49:16 +0000] [/wp-content/w3tc/min/72b8dd/default.include-footer.1418282203.js] [http://loveandtrash.com/] A group configuration for "include-footer" was not set
    [Tue, 05 Jul 2011 02:49:16 +0000] [/wp-content/w3tc/min/72b8dd/default.include-footer-nb.1471229315.js] [http://loveandtrash.com/] A group configuration for "include-footer-nb" was not set
    [Wed, 06 Jul 2011 07:48:21 +0000] [/wp-content/w3tc/min/75c32d/default.include-nb.3650049168.js] [-] A group configuration for "include-nb" was not set
  10. mikehenrysr
    Member
    Posted 3 years ago #

    I too am getting the error, many more times than the log file shows. There's nothing in the debug content at the bottom of the .html. However I'm getting many more notifications than errors showing in the log. And all of my errors are "Get['f'] param invalid: "". I'm running 3.1.5 (or whatever is right before 3.2).

    [Fri, 01 Jul 2011 01:41:41 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/professional-intimacy-secret-sustainable-leaders/] GET['f'] param invalid: ""
    [Fri, 01 Jul 2011 01:42:57 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/the-art-of-disruption/] GET['f'] param invalid: ""
    [Fri, 01 Jul 2011 01:46:01 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/the-art-of-disruption/] GET['f'] param invalid: ""
    [Wed, 06 Jul 2011 22:07:02 +0000] [/wp-content/w3tc/min/index.php?file=a27498db.a25d8e.js] [http://leadchangegroup.com/blog/] GET['f'] param invalid: ""
    [Wed, 06 Jul 2011 22:07:27 +0000] [/wp-content/w3tc/min/index.php?file=a27498db.a25d8e.js] [http://leadchangegroup.com/author/heatherecoleman/] GET['f'] param invalid: ""
    [Wed, 06 Jul 2011 22:07:30 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET['f'] param invalid: ""
    [Wed, 06 Jul 2011 22:07:37 +0000] [/wp-content/w3tc/min/index.php?file=12aea2cc.8fe080.css] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET['f'] param invalid: ""
    [Wed, 06 Jul 2011 22:08:07 +0000] [/wp-content/w3tc/min/index.php?file=656ab810.9f2d93.js] [http://leadchangegroup.com/receiving-input-from-dilbert/] GET['f'] param invalid: ""

  11. Rickard Andersson
    Member
    Posted 3 years ago #

    I'm having the same problem, but I just got it working and after starting to configure another site in the same installation (WP 3.2 multisite with domain mapping) the js/css minification suddenly broke.

    The error in the log is

    [Thu, 14 Jul 2011 11:35:57 +0000] [/wp-content/w3tc-0x539.se/min/da7a6d62.ec36f0.js] [-] GET['f'] param invalid: ""

    Could this be some problem with .htaccess file/files? I know when i started to configure the other site the first message was that the .htaccess file needed to be updated.

    Current .htaccess config file: http://pastebin.com/J8RhtBLG

  12. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry for the trouble. I wonder if anyone having this issue could please submit a bug submission form from the support tab of the plugin if they're already using the latest version of the plugin?

  13. mikehenrysr
    Member
    Posted 2 years ago #

    @Frederick, I just opened a ticket on the issue and linked to this thread too. Thanks!

  14. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Ok.

  15. efikim
    Member
    Posted 2 years ago #

    I got the same error message today, though nothing has been changed in the W3TC configuration for a few days.

    enabled minify debug and it doesn't show any errors just lists the replaced css and js files

    (wordpress 3.2.1, twenty eleven theme)

  16. Rickard Andersson
    Member
    Posted 2 years ago #

    @Frederick I did a bug report when I was investigating this issue. I can't really find any reference number to it, but in the report I did reference this forum thread.

    Hope it helps, just contact me if you need further help investigating this issue.

  17. outercript
    Member
    Posted 2 years ago #

    I get the same error as you [-] GET['f'] param invalid: "" with 2 css files. And debugging dont provide relevant information to isolate the problem.

    I'm running WordPress 3.2.1, PHP 5.2.17.

  18. Mike McQuaid
    Member
    Posted 2 years ago #

    I've got the same issue.

  19. Cam Nick
    Member
    Posted 2 years ago #

    I keep getting this error in my admin panel

    "Recently an error occurred while creating the CSS / JS minify cache: Some files were unavailable"

    When i check the error log the most common error i see is below.

    "/wp-content/w3tc/min/e753e/single.include-nb.9865d5.js] [-] A group configuration for "include-nb" was not set"

    How do i fix this error or what do i need to look for. Because i follow the recommended settings for minify.

    Thanks

  20. war59312
    Member
    Posted 2 years ago #

    Not working here either.

    Even worse, I don't even have an error log in "/usr/local/nginx/html/wp-content/w3tc/min". :(

    I'm sure it's a permission issue some where as the files don't even exist.

    Nothing in nginx logs about it either. Lame!

    Also tried running this but did NOT help:

    sudo chmod -R 777 /usr/local/nginx/html/wp-content/w3tc/

    There is only 1 file in this entire directory and that is "index.php" in "min".

    And yes W3 Total Cache successfully recreates the folder if I disable and the re-enable the plug-in.

    Update: Work-around is to disable "Rewrite URL structure" on "Minify" page.

  21. Rickard Andersson
    Member
    Posted 2 years ago #

    Did some more debugging today and got it working again by disabling the "Rewrite URL structure" option under the settings for minification.

    EDIT: Upon further investigation it seems like it's minification with memcached that's causing the problem and not the rewrite URL structure setting.

  22. Ken Storch
    Member
    Posted 2 years ago #

    Perhaps my issue is similar.
    After my last reinstall of W3tc, I don't have "Rewrite URL structure" checked and still have problems.

    I've been detailing them (at length, admittedly) at this thread:
    http://wordpress.org/support/topic/w3-total-cache-pages-dont-gzip-or-cache?replies=5#post-2280907

    If these issues are not related, then I'll be sorry for the misdirection.

  23. David Radovanovic
    Member
    Posted 2 years ago #

    Was this ever resolved? Thanks!

  24. David Radovanovic
    Member
    Posted 2 years ago #

    Ended up just unchecking the enable Minify in General Settings.

  25. scottdaris
    Member
    Posted 2 years ago #

    I don't know if this applies, but see my post about automatic minifying errors:
    http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify
    (btw, I meant to say *Important* parsing error found with automatic minify)
    In the minifying process, incorrect .js code was generated. You'll see what I mean in my post. Good luck!

  26. shaliam
    Member
    Posted 2 years ago #

    I am curious how many were/are using "comment luv" thesetwo plugins seem to conflict and comment luv just revised their plugin to end the conflicts. The problem is the conflict is resolved but the script issues with css and js are not resolved, seems only manual line by line review will have to occur (see http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify )to fix unless anyone else has any suggestions???

  27. Mike McKoy
    Member
    Posted 2 years ago #

    Hi Fredrick,

    This is an awesome plugin. Has any progress been made to fix the bug? I was using automatic (which I used in the previous version). I switched over to manual and i'm getting the errors all the others are getting as well.

    Hope to go back to using automatic soon. I don't know anything about configuring this plugin. :(

    Very complicated stuff

  28. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    This functionality really gives too many false positives right now and should be disabled.

  29. jamminjames
    Member
    Posted 2 years ago #

    I got this error for a plugin that had been disabled and completely deleted. I checked the database, and there were no leftover tables from it. Since nothing is left of the old plugin, what could be making the cache want to create a css minify for it? How can I delete whatever traces seem to be left?

    It's not a matter of flushing the cache, as all caches have been emptied many times since I deleted this plugin.

    Recently an error occurred while creating the CSS / JS minify cache: File "/usr/home/wheel/humortimes/wordpress/wp-content/plugins/twitter-facebook-google-plusone-share/tfg_style.css" doesn't exist.

    Thanks for any help.

  30. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Are you sure that you're viewing the list of all plugins because it's not possible that you're still seeing errors related to the plugin if it's removed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic