WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Problems with dev version - cdn css background urls + no minify files to up (12 posts)

  1. shortster
    Member
    Posted 4 years ago #

    My first problem occurred when I moved my local site on localhost:8888/mywebsite to my server at http://www.mywebsite.com/tst. After moving the files and importing the database, in which I did a find and replace of the servername, I logged in to wp-admin and changed my cdn (s3) from static.dev.mywebsite.com to static.tst.mywebsite.com. After this I changed all the urls in the minify settings. I uploaded all my files to static.tst.mywebsite.com through the plugin, emptied all the caches en loaded my site in the browser. Everything was fine except my background images weren't there. In firebug I saw that in my minified css on static.tst.mywebsite.com all my background images urls were still pointing to /mywebsite/pathtoimage/image.jpg instead of to /tst/pathtoimage/image.jpg.

    After trying a lot of things and rechecking everything twice I gave up and decided to start from scratch, which led me to my second problem.

    So now I have a clean wp 3.0 install on my server, installed all my plugins and redid all my settings. After everything was ok I installed w3 total cache (development version again). After setting the writing permissions to wp-config and .htaccess all was good. Then I entered all my js and css urls in the minify settings and checked in the browser (love the preview mode btw). Still doing great so far. Now I activated the cdn setting and entered my bucket info. Then when I want to upload the minified files it says Total files: 0. Other files upload fine. And the css/js files aren't loaded in the browser. Strange thing is that when I try the url to a gzip minified file on the cdn I get an xml with access denied. Permissions problem somewhere?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    S3 bucket "permissions" are inadequate or you're using a CNAME that is not authorized. Either create a new bucket using the plugin or use another tool to modify the access control list for the existing bucket.

  3. shortster
    Member
    Posted 4 years ago #

    Hi Frederick,

    Thanks for your quick reply! Unfortunately bucket permissions or CNAME does not seem to be the problem.

    I made a new s3 bucket from within the plugin, did the test upload and was ok. I'm not using a CNAME (still have to find out how CNAMEs work).
    All files are uploading ok, but when I select 'Upload minify files' the popup still says 0 files to upload..

    With cdn disabled the minified files work perfectly.

  4. shortster
    Member
    Posted 4 years ago #

    I've even tried setting the bucket permissions list and update/delete to 'everyone' in the AWS management console for s3. But no luck.

  5. blau
    Member
    Posted 4 years ago #

    I don't use S3 directly but Cloudfront with success:

    I added up to 10 CNAME to cloudfront (media1.mysite.tld media2 media3...), added the 10 CNAMEs in my site DNS so that I have somethinh like

    media1.mysite.tld CNAME mycloudfronturl.cloudfront.net
    etcetera

  6. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Can you submit a bug submission report from the support tab of the plugin?

  7. shortster
    Member
    Posted 4 years ago #

    I did a bug submission, thanks for your work and support.

  8. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    I don't know your real name @shortster. Did I resolve your issue?

  9. shortster
    Member
    Posted 4 years ago #

    Yes you fixed it! For anyone else with the same problem. It was a permissions issue on the w3tc/min folder on the server.

  10. shortster
    Member
    Posted 4 years ago #

    O btw, my name is Sjoerd

  11. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Ok great.

  12. fsakbas
    Member
    Posted 3 years ago #

    firstly sorry my english. i hope understand me.

    i am using w3 total cache and aws for cdn. its working good. but i have a little problem for background urls. <div class="slide-box" style="background:url(<?php wp_get_attachment_url( get_post_thumbnail_id( $post->ID ) ); ?>) no-repeat;">

    <div class="slide-box" style="background:url(http://www.212medya.com/wp-content/uploads/2011/04/yeni-nesil-web-tasarim.jpg) no-repeat;">

    i want to change like this<div class="slide-box" style="background:url(http://cdn.212medya.com/wp-content/uploads/2011/04/yeni-nesil-web-tasarim.jpg) no-repeat;">

    background url dosnt rewrite to cdn. how can i fix it

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic