WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Permalink Change (7 posts)

  1. noisegate95
    Member
    Posted 2 years ago #

    I would like to update my permalinks, which I did no problem. I know that WordPress adds rewrites to the htaccess file so that your search engine results are accessible from the old links. However, when I changed my permalinks, that was not the case. Going to the W3 Total Cache page, it tells me that the page cache is not active, and when I choose auto-install, these permalinks do not work with the Google (old) search results. I have tried to deactivate W3 then change permalinks, I also uploaded all my content to my CDN. Can anyone tell me what I am failing to do?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Can you disable page caching and then re-enable it?

  3. noisegate95
    Member
    Posted 2 years ago #

    "I have tried to deactivate W3 then change permalinks,"

  4. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry, what do you mean exactly?

  5. noisegate95
    Member
    Posted 2 years ago #

    Disabling W3 Total Cache, changing the permalinks to %postid, re-enabling W3, and uploading all to CDN (I am using Push) does not seem work. When going to the old permalink, it does not find the new permalink, therefore 404'ing.

  6. noisegate95
    Member
    Posted 1 year ago #

    No ideas? Any troubleshooting assistance would be greatly appreciated.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    You should try to delete the W3TC rules from the .htaccess file and let it re-add them so that your changes are respected.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic