WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Plugin gives me 404 in front page (14 posts)

  1. Julian Fernandes
    Member
    Posted 1 year ago #

    Hello,
    I have been using W3 Total Cache for years now, and this is the first time i ever saw this problem.

    Today while i was taking a look at my logs i saw a 404 error in front page, so i went to the browser to take a look and surprise... front page was really giving me 404.

    I desactivated all plugins and activated one by one... and when i activate W3 Total Cache, booom... 404 error. Then i desactivated everything again, deleted W3 Total Cache and downloaded the dev version (10 months old?). Activated only the dev version... and got 404 page, so yeah... W3 Total Cache is the issue here.

    I have a VPS with 768MB RAM and 1 core CPU. I use Nginx as my webserver and php-fpm for PHP. I also use Varnish, APC and CloudFlare Pro if that counts.

    I have been in this VPS that i setup for about 15 days, and this is the first time i saw this error. It actualy showed up on the acess log only today, so i really have no clue about why it happened... it also happens only in front page, any other pages are works fine and posts too.

    This my default.conf Nginx's config: http://paste.ubuntu.com/1063432/
    My Nginx's main config looks like this: http://paste.ubuntu.com/1063434/
    My php-fpm default pool looks like this: http://paste.ubuntu.com/1063435/

    The only change i did on my website today was change php-fpm settings from dynamic to ondemand, but i changed it back and error still happens.

    Right now i have disabled W3 Total Cache and setup CloudFlare to do the minify, configured browser cache direcly in Nginx and let WP's default cache active (same for php's one)... but website is slower ofc, since i don't have all the great stuffs of W3 Total Cache on.

    So... anyone can help me with this or have experienced the same problem? I really love this plugin, but Frederick don't really help and all he does in the rare ocasions he appears is say "it's fixed in the next release"... i understand he is a busy man with Mashable being a huge site and all, but... damm :/

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    I need to know more about what modules you were using when you started getting 404s. What settings were in place. Also have you remembered to restart/reload nginx after making changes in w3tc settings. Emptied APC and such as well?

    Can you submit a bug submission form from the support tab of the plugin?

  3. Julian Fernandes
    Member
    Posted 1 year ago #

    Just the ones i said on the post: Nginx, php-fpm, APC, Varnish and CloudFlare Pro (not related, i guess).

    I also use Ubuntu Server 12.04, if that worth of anything.

    I restarted Nginx, Varnish and php-fpm when i made changes and when the 404 error started to show. Then i deleted all the plugin's files (including the ones in wp-content) and downloaded the dev version... instaled, restarted all the services, and everything seems to work.. then some minutes later, 404 page again. The APC i use is php5-apc by the way.

    I can't submit a bug report cause that means activating the plugin... and getting 404 again :/
    Since the error started to happen just now, maybe the server hit some kind of limitation? Is that possible?

    The CPU usage is always at 8% and RAM usage is 200MB at max, when there are like, 50~80 users online at the same time.

    Nothing really changed besides the dynamic to ondemand.. that i changed back. Even the visitors are the same, we never got more than 80 online at same time, and at the time the 404 showed up, there was 20 only.

    I have php.ini set to 64mb RAM... then i increased to 128MB when the 404 started to appear, thinking it could be something related, but nops... still happens. There is also nothing in Nginx's or PHP error logs.

  4. Julian Fernandes
    Member
    Posted 1 year ago #

    Installed the plugin again and disabled Page Cache, since it seems to be the problem.

    I sent you a bug report, like you asked :)

  5. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Ok.

  6. rahul286
    Member
    Posted 1 year ago #

    @Julian
    You no need to disable page-caching.

    You can use W3 Total Cache with page-caching by following http://rtcamp.com/tutorials/standard-wordpress-nginx-w3-total-cache/

    I will advise you to not use Varnish as Nginx itself is very lightweight.

    For Nginx error logs, you can turn on debugging. See http://rtcamp.com/tutorials/debugging-nginx-configuration/

    Ignore PHP logs as when using PHP via FPM, behind Nginx, PHP errors will be logged in Nginx's error log by default.

  7. Julian Fernandes
    Member
    Posted 1 year ago #

    @rahul286 Thanks for the feedback :)

    But i actually don't use Varnish or Page cache with W3 Total Cache anymore. Right now i use Nginx with microcache, W3 Total Cache for Minify and CDN, and APC/Batcache for the rest.

  8. rahul286
    Member
    Posted 1 year ago #

    @Julian

    By microcache do u mean nginx's fastcgi_cache?

  9. Julian Fernandes
    Member
    Posted 1 year ago #

  10. rahul286
    Member
    Posted 1 year ago #

    @Julian cool :-)

    (You may be already doing it...) just move nginx's cache folder to RAM i.e. tmpfs
    It will further improve performance.

    I covered it in - http://rtcamp.com/tutorials/wordpress-nginx-fastcgi-cache-purge-conditional/

  11. Julian Fernandes
    Member
    Posted 1 year ago #

    @rahul286 Did that too! :D
    But only on a 2GB RAM VPS. On my 512MB one, i keep it on SSD disks.

  12. rahul286
    Member
    Posted 1 year ago #

    On SSD, you are already having better disk performance. :-)

    Actually if RAM is free, OS will "cache" disk pages into RAM anyway.

    We are using a dedicated server with 32GB RAM. But I am very greedy for performance! :D

    I changed APC's default cache size from 32MB to 1GB and it also improved performance magically. I also changed max single item storage limit from 1 MB to 10MB in APC settings.

    Apart from APC, also allotted very large cache/buffers for mysql.

  13. Julian Fernandes
    Member
    Posted 1 year ago #

    Join the club! Performance and content is all i think about xD

  14. gixty7
    Member
    Posted 1 year ago #

    from time to time I get a 404 cached homepage. What setting do i need to modify to avoid this behavior?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic