WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Permissions Problem - Forbidden to access _default_.html.gzip (13 posts)

  1. nhowarth
    Member
    Posted 4 years ago #

    I have installed the plugin and activated it (without changing any of the configuration settings) and get an error when accessing the site:

    Forbidden

    You don't have permission to access /wp-content/w3tc/pgcache//_default_.html.gzip on this server.
    ________________________________________
    Apache/2.2.3 (CentOS) Server at http://www.news.cyprus-property-buyers.com Port 80

    Permissions set as follows:
    wp - 755 (folder containing WordPress)
    wp-content - 755
    w3tc - 755
    pgcache - 755
    _default_.html.gzip - 600

    I have set the page cache to 'Disk (enhanced)' and 'Disk (basic)', and disabled everything else, but the problem persists.

    Any thoughts?

    TIA

  2. Frederick Townes
    Member
    Posted 4 years ago #

    Can you paste the contents of your .htaccess file? You said that the issue still occurs when you use the disk basic method for page cache? That should be impossible it's a completely different engine.

  3. Frederick Townes
    Member
    Posted 4 years ago #

    Can you paste the contents of your .htaccess file? You said that the issue still occurs when you use the disk basic method for page cache? That should be impossible it's a completely different engine.

  4. Frederick Townes
    Member
    Posted 4 years ago #

    Can you paste the contents of your .htaccess file? You said that the issue still occurs when you use the disk basic method for page cache? That should be impossible it's a completely different engine.

  5. nhowarth
    Member
    Posted 4 years ago #

    Frederick,

    Problem solved my error - plugin working using 'Disc (basic)'.

    Thanks, Nigel

  6. Frederick Townes
    Member
    Posted 4 years ago #

    Ok. I would still like to see your .htaccess file if you don't mind.

  7. nhowarth
    Member
    Posted 4 years ago #

    Hi Frederick,

    Here's the .htaccess from the /wp-content/w3tc/min folder. Is this the one you want?

    # BEGIN W3TC Minify
    <IfModule mod_mime.c>
    AddEncoding gzip .gzip
    <Files *.css.gzip>
    ForceType text/css
    </Files>
    <Files *.js.gzip>
    ForceType application/x-javascript
    </Files>
    AddEncoding deflate .deflate
    <Files *.css.deflate>
    ForceType text/css
    </Files>
    <Files *.js.deflate>
    ForceType application/x-javascript
    </Files>
    </IfModule>
    <IfModule mod_setenvif.c>
    SetEnvIfNoCase Accept-Encoding (gzip|deflate) APPEND_EXT=.$1
    <IfModule mod_deflate.c>
    SetEnvIfNoCase Request_URI \.(gzip|deflate)$ no-gzip
    </IfModule>
    </IfModule>
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/css M86400
    ExpiresByType application/x-javascript M86400
    </IfModule>
    <IfModule mod_headers.c>
    Header set Pragma public
    Header set X-Powered-By "W3 Total Cache/0.8.5.2"
    Header set Vary "Accept-Encoding"
    Header append Cache-Control "public, must-revalidate, proxy-revalidate"
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME}%{ENV:APPEND_EXT} -f
    RewriteRule (.*) $1%{ENV:APPEND_EXT} [L]
    RewriteRule ^([a-z0-9\-_]+)\.(include(-footer)?(-nb)?)\.(css|js)$ index.php?gg=$1&g=$2&t=$5 [L]
    </IfModule>
    # END W3TC Minify

    Regards,

    Nigel

  8. Frederick Townes
    Member
    Posted 4 years ago #

    No, I want the one from your document root.

  9. nhowarth
    Member
    Posted 4 years ago #

    Here's the one in the root directory of my site:

    SetEnv DEFAULT_PHP_VERSION 5
    Options -Indexes
    SetEnv PHP_EXTENSION .html
    AddType application/x-httpd-php .php .html .htm

    and the one from the WordPress directory:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  10. Frederick Townes
    Member
    Posted 4 years ago #

    There must be some directive in http.conf preventing access to files of this type. Are you able to confirm?

  11. crowntastic
    Member
    Posted 3 years ago #

    Hi. I had the same problem. I switched page caching to disc basic and it worked.

  12. Frederick Townes
    Member
    Posted 3 years ago #

    @nhowarth? The way that this problem occurs by a conflict with some other directives only.

  13. Frederick Townes - I was able to repro this on MultiSite in a weird way.

    The subDIRECTORY install is fine with enhanced. The subDOMAIN install barfs unless it's basic.

    Each install has w3tc activated and configured PER site (no network activation or MU stuff, just one install and then a config done manually per site).

    Don't know if that helps you!

Topic Closed

This topic has been closed to new replies.

About this Topic