WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
param "?9d7bd4" added to images: bad user experience in web app m (4 posts)

  1. two7s_clash
    Member
    Posted 2 years ago #

    Hello, I'm using W3 Total Cache with WPTouch. I filled the below ticket with them. They wrote me back, saying the the culprit was likely the param "?9d7bd4" appended to the end of the image name. Is Total Cache adding this? I've already added all the suggested Rejected User Agents.

    Could you comment on the exchange below?

    ============================================

    Hi,

    In most of the posts on my site, embedded images link to the actual image file. I'm also using Web-App mode. But since Web-App mode has no back button, a user can follow a link to a image and become "stranded" there. Any know work-arounds or suggestions?

    Site is mbird.com

    Thanks.

    Hi James,

    In web-app mode images linked to their larger versions shouldn't open. I see that there's some sort of ID attached to the end of your images' URLs (wp-content/uploads/2011/08/xr7ky-337x500.jpg?9d7bd4). I belive that is what is causing the issue. Do you know what is adding that number at the end?

  2. magicwings
    Member
    Posted 2 years ago #

    I had this problem myself and have finally found both the cause and a solution.

    It is caused by the plugin W3 Total Cache, under the Browser Cache settings.

    At the bottom, you have checked the following setting:

    Prevent caching of objects after settings change
    Whenever settings are changed, a new query string will be generated and appended to objects allowing the new policy to be applied.

    This adds an appropriate string to the end of all images called through CDN or otherwise. Uncheck that box and purge/refresh the cache to see the difference.

    Hope this helps.

  3. Ammalgam
    Member
    Posted 1 year ago #

    GOD BLESS YOU!

    I'll name my next kid after you! This has been a problem for me for 24 hours and I was hunting down jquery conflicts in vain.

    Thanks...

  4. Ammalgam
    Member
    Posted 1 year ago #

    Spoke too soon. It was working and now it's not...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic