WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] PageSpeed Still Says I Need Browser Caching (13 posts)

  1. agfreesafety
    Member
    Posted 2 years ago #

    I installed W3 Total Cache on my site.

    I followed these instructions to set up browser caching, but for some reason, when I run the Google PageSpeed test, it's still telling me that I need to enable browser caching.

    I thought it might take a day or so for the changes to take effect, but it's been over 24 hours since I set this stuff up.

    When I click on the "Leverage Browser Caching" link at the PageSpeed site, it says:

    The following cacheable resources have a short freshness lifetime. Specify an expiration at least one week in the future for the following resources:

    Then it proceeds to list a bunch of URL's and each URL says (expiration not specified) after it.

    Any idea why the browser caching doesn't seem to be working?

  2. itrogers
    Member
    Posted 2 years ago #

    Found this thread through a Google alert. It's funny, as I actually wrote the post you mentioned. Thanks for reading.

    I am looking at your Google Page Speed report and your browser cache seems to be configured correctly for the URLs and assets on your own server. The URLS you are looking at in the Page Speed report are all external. As far as I know, W3TC only caches URLs on your own domain. I have been looking for a solution as well to cache external URLs, or at least make period copies and cache those. If I find anything, I'll make sure I post here.

  3. agfreesafety
    Member
    Posted 2 years ago #

    Ha! Thanks for that guide. I was lost without it.

  4. agfreesafety
    Member
    Posted 2 years ago #

    oh by the way, I noticed that many of the webpages referenced in the Page Speed thing were on my domain. About nine, to be exact.

  5. itrogers
    Member
    Posted 2 years ago #

    Interesting- as I am only getting external URLs. Have you tired clearing all caches, refreshing the page, and running the tool again? I use the developer chrome chrome extension. I get an 80/100 for your site.

  6. agfreesafety
    Member
    Posted 2 years ago #

    Are you referring to my own browser's cache, or a cache related to the website?

  7. itrogers
    Member
    Posted 2 years ago #

    The cache related to your website.

  8. Frederick Townes
    Member
    Posted 2 years ago #

    @agfreesafety, are the files that are failing in your report actually hosted by you or are they 3rd party resources?

  9. agfreesafety
    Member
    Posted 2 years ago #

    As you can see in this screenshot, most of them appear to be hosted by me.

  10. Frederick Townes
    Member
    Posted 2 years ago #

    Which options are enabled on the browser cache settings tab?

  11. agfreesafety
    Member
    Posted 2 years ago #

    Hi Frederick, my Browser Settings tab is set up exactly how these directions say it should be.

    I figured sending you a visual of what it looks like may be easier than typing out what all is enabled.

  12. Frederick Townes
    Member
    Posted 2 years ago #

    You need to enable cache control, so those directions are not complete. You also probably don't want to use eTag unless you're sure you want that.

  13. itrogers
    Member
    Posted 2 years ago #

    Frederick is right- you should enable Cache control. My post is in need of some updating.

Topic Closed

This topic has been closed to new replies.

About this Topic