WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] pagespeed says I need to compress (7 posts)

  1. meeble
    Member
    Posted 2 years ago #

    Hi,

    I am using W3TC and have all HTTP compression options enabled - I am also minifying JS and CSS. Yet, when I run Google pagespeed, it tells me I need to enable compression. It lists various JS and CSS files - mostly from my Lightbox plugin - why aren't they being compressed?

    I am using these settings:
    JS minifier: JSmin
    CSS minifier: Default

    HTML minify settings: Enabled, Inline CSS minification enabled, Inline JS minification enabled. For CSS and JS, I have them enabled and also Preserved comment removal enabled.

    I also have HTTP (gzip) compression enabled for CSS & JS on the browser cache settings tab.

    This is the website: Mr. Meeble

    http://wordpress.org/extend/plugins/w3-total-cache/

    Thanks

  2. kaidez
    Member
    Posted 2 years ago #

    Hi Meeble. I ran Page Speed on my end and sadly, it looks like none of the CSS or JS is compressed. You may have to run it again so that it forces both the "Empty the page cache" and "Empty the minify cache" buttons appear at the top W3TC's panel in WordPress. The best way to do that is to go to W3TC's Minify section, uncheck "Enable" under the JS section, and click any on of the "Save all settings" buttons. When thse two buttons appear at the top, click both of them.

    Then go back and check the "enable" button and hit "Save all settings" again. Those to buttons will appear at the top again...click them again and the CSS and JS should minify at that point.

    Make sure to review this W3TC guide over at http://zemalf.com/1443/w3-total-cache/ . It's slightly out of date and doesn't cover every feature in the current version of W3TC, but it covers more than enough to get you started. There's a slide show link in at the bottom of the article that's more up-to-date.

    HTH,
    -kaidez

  3. meeble
    Member
    Posted 2 years ago #

    Hi kaidez,

    Thanks - I'll try your idea and let you know if it worked for me.

  4. meeble
    Member
    Posted 2 years ago #

    I'm still having the same problem. Also, something about W3TC minify being enabled keeps breaking my RSS feed for the site. hmmm...

  5. Frederick Townes
    Member
    Posted 2 years ago #

    You shouldn't minify your RSS unless you absolutely have to. It's disabled by default.

  6. achrysalis
    Member
    Posted 2 years ago #

    Hello, I am having the same issue.

    I've followed your steps above to disable, empty the cache, re-enable and am still showing poor performance on Google Page Speed across the site (www.legacymultimedia.com).

    The pagespeed report tells me to enable compression on all the js scripts - a number of which I've entered into W3TC by hand. I'm running manual because auto breaks my homepage slideshow.

    Anyway, I'd appreciate any support you can provide. I've read and googled and tweaked for hours and am having limited success.

    Thanks!
    A

    [ Please do not bump, it's not permitted here. ]

  7. Frederick Townes
    Member
    Posted 1 year ago #

    Unsure of what your browser cache settings are, but W3TC tries to compression your text-based files if you have that option enabled, if not only minified files are compressed. If you want a professional tuning the support options for that are in the plugin otherwise various guides online can hopefully help you for free.

Topic Closed

This topic has been closed to new replies.

About this Topic