WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] Pages Not Getting Cached ?! (11 posts)

  1. Chukwudi Emmanuel Udegbunam
    Member
    Posted 4 years ago #

    I enabled the debugging mode on my blog and I'm getting the folowing data

    <!-- W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Key: _default_.html
    Caching: disabled
    Reject reason: cookie is rejected
    Status: not cached
    Creation Time: 0.681s
    Header info:
    X-Powered-By: W3 Total Cache/0.8.5.2
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: _percent_mobile_c=844669089972830_1274981633_161809981716270; expires=Fri, 27-May-2011 16:33:53 GMT; path=/
    X-Pingback: http://www.strictlyonlinebiz.com/blog/xmlrpc.php
    Content-Type: text/html; charset=UTF-8
    X-Mobilized-By: WordPress Mobile Pack 1.2.1
    Link: <http://wp.me/Lutj>; rel=shortlink
    -->

    Could you please explain why it says caching disabled etc? Is the page not getting cached or what.

    The debug mode is still activated pending when you reply. Thanks

  2. the_loop
    Member
    Posted 4 years ago #

    "Disk enhanched" doesn't work for me... neither I see debug when it's active. I must use "disk" only.
    Just my experience.

  3. Chukwudi Emmanuel Udegbunam
    Member
    Posted 4 years ago #

    Thanks for your help but even with disk, I'm still getting the same message.

    <!-- W3 Total Cache: Page cache debug info:
    Engine: disk
    Key: w3tc_9753a0fbe72f9eb9bb89dc7906b302f1_page_f7aa5e7d8164aa09aacfe1de7eb14da6
    Caching: disabled
    Reject reason: cookie is rejected
    Status: not cached
    Creation Time: 0.820s
    Header info:
    X-Powered-By: W3 Total Cache/0.8.5.2
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Set-Cookie: _percent_mobile_c=844669089972830_1275060587_165618906298050; expires=Sat, 28-May-2011 14:29:47 GMT; path=/
    X-Pingback: http://www.strictlyonlinebiz.com/blog/xmlrpc.php
    Content-Type: text/html; charset=UTF-8
    X-Mobilized-By: WordPress Mobile Pack 1.2.1
    Link: <http://wp.me/Lutj>; rel=shortlink
    -->

    Anymore tips? Anyone?

  4. Frederick Townes
    Member
    Posted 4 years ago #

    cookie is rejected is default WP logic, it means that you submitted a comment and so a cookie was set to make sure that you got a fresh page after submission. Clear your cookies or wait for the cookie to expire. Or just open up another browser.

  5. mskogly
    Member
    Posted 4 years ago #

    I installed the WPDB Profiling plugin, and it doesn't seem like anything gets cached. Compared when running with page caching (to disk) enabled and not, but can't really see a difference. I've deselected the Don't cache pages for logged in users - option under Page Cache settings.

    Or am I missing something?

  6. mskogly
    Member
    Posted 4 years ago #

    Changed from disk (enhanced) to disk (basic). Turned on debug, logged out, reloaded a few times.

    Page cache:
    Caching: enabled
    Status: not cached

    Any opinions on why it doesn't seem to want to cache the page?

  7. Frederick Townes
    Member
    Posted 4 years ago #

    Hard to say, can you submit a bug submission via the support tab?

  8. Chukwudi Emmanuel Udegbunam
    Member
    Posted 4 years ago #

    Despite clearing cookies and deactivating anything that can cause Pages not to cache, there are still no getting cached.
    I was wondering if you could take a look @ my htaccess to see if something is wrong.
    Here goes

    # BEGIN W3 Total Cache
    <IfModule mod_setenvif.c>
    SetEnvIfNoCase Accept-Encoding (gzip) APPEND_EXT=.$1
    </IfModule>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register).php|wp-.*\.php|index\.php) [OR]
    RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
    RewriteCond %{HTTP_USER_AGENT} !(bot|ia_archive|slurp|crawl|spider|2\.0\ MMP|240x320|ASUS|AU-MIC|Alcatel|Amoi|Android|Audiovox|AvantGo|BenQ|Bird|BlackBerry|Blazer|CDM|Cellphone|DDIPOCKET|Danger|DoCoMo|Elaine/3\.0|Ericsson|EudoraWeb|Fly|HP\.iPAQ|Haier|Huawei|IEMobile|J-PHONE|KDDI|KONKA|KWC|KYOCERA/WX310K|LG|LG/U990|Lenovo|MIDP-2\.0|MMEF20|MOT-V|MobilePhone|Motorola|NEWGEN|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Novarra|O2|Opera\ Mini|Opera\.Mobi|PANTECH|PDXGW|PG|PPC|PT|Palm|Panasonic|Philips|Playstation\ Portable|ProxiNet|Proxinet|Qtek|SCH|SEC|SGH|SHARP-TQ-GX10|SPH|Sagem|Samsung|Sanyo|Sendo|Sharp|Small|Smartphone|SoftBank|SonyEricsson|Symbian|Symbian\ OS|SymbianOS|TS21i-10|Toshiba|Treo|UP\.Browser|UP\.Link|UTS|Vertu|WILLCOME|WinWAP|Windows\ CE|Windows\.CE|Xda|ZTE|dopod|hiptop|htc|i-mobile|iPhone|iPod|nokia|portalmmm|vodafone) [NC]
    RewriteCond /home/vta2008/public_html/blog/wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} -f
    RewriteRule (.*) wp-content/w3tc/pgcache/$1/_default_.html%{ENV:APPEND_EXT} [L]
    </IfModule>
    # END W3 Total Cache

    RewriteEngine On
    RewriteRule .* - [E=HTTP_IF_MODIFIED_SINCE:%{HTTP:If-Modified-Since}]
    RewriteRule .* - [E=HTTP_IF_NONE_MATCH:%{HTTP:If-None-Match}]
    # BEGIN Define Mime Types (in case /etc/mime.types is poorly configured or incorrect)
    <IfModule mod_mime.c>
    AddType application/x-javascript .js
    AddType application/x-shockwave-flash .swf
    AddType image/bmp .bmp
    AddType image/gif .gif
    AddType image/pjpeg .pjpeg
    AddType image/jpeg .jpeg
    AddType image/jpg .jpg
    AddType image/png .png
    AddType image/svg+xml .svg
    AddType image/tif .tif
    AddType image/tiff .tiff
    AddType image/x-icon .ico
    AddType text/css .css
    AddType text/htm .htm
    AddType text/html .html
    AddType text/plain .txt
    AddType text/xml .xml
    AddType text/xsd .xsd
    AddType text/xsl .xsl
    </IfModule>
    # END Define Mime Types

    # BEGIN HTTP Compression
    <IfModule mod_deflate.c>
    # Netscape 4.x has some problems...
    BrowserMatch ^Mozilla/4 gzip-only-text/html
    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip
    # MSIE masquerades as Netscape, but it is fine
    BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won't work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
    # Don't compress media or scripts
    SetEnvIfNoCase Request_URI (?:bmp|gif|jpe?g|php|png|swf|tiff?)$ no-gzip dont-vary
    # Make sure proxies don't deliver the wrong content
    Header append Vary User-Agent env=!dont-vary
    # Fragment size to be compressed at one time by zlib
    #DeflateBufferSize 4096
    # Amount of compression applied to output
    #DeflateCompressionLevel 9
    # How much memory should be used by zlib for compression
    #DeflateMemLevel 9
    # Zlib compression window size
    #DeflateWindowSize 15
    # Enable HTTP Compression policy for all except .css, .js and .html documents
    SetOutputFilter DEFLATE
    AddOutputFilterByType DEFLATE text/css text/plain text/html text/xml text/xsd text/xsl application/x-javascript \
    \. application/wlwmanifest+xml image/svg+xml image/x-icon
    </IfModule>
    # END HTTP Compression

    # BEGIN Headers: Ensure browser caching of objects for 30 days
    # Set Expires header
    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType application/x-javascript A2592000
    ExpiresByType application/x-shockwave-flash A2592000
    ExpiresByType application/wlwmanifest+xml A2592000
    ExpiresByType image/bmp A2592000
    ExpiresByType image/gif A2592000
    ExpiresByType image/pjpeg A2592000
    ExpiresByType image/jpeg A2592000
    ExpiresByType image/jpg A2592000
    ExpiresByType image/png A2592000
    ExpiresByType image/svg+xml A2592000
    ExpiresByType image/tif A2592000
    ExpiresByType image/tiff A2592000
    ExpiresByType image/x-icon A2592000
    ExpiresByType text/css A86400
    ExpiresByType text/htm A2592000
    ExpiresByType text/html A2592000
    ExpiresByType text/plain A2592000
    ExpiresByType text/xml A2592000
    ExpiresByType text/xsd A2592000
    ExpiresByType text/xsl A2592000
    </IfModule>

    <FilesMatch "\.(bmp|css|ico|html?|js|tiff?|gif|p?jpe?g|png|svgz?|swf|txt|xsd|xsl|xml)$">
    <IfModule mod_headers.c>
    # Set Pragma header
    Header set Pragma "public"
    # Set Cache-Control header
    Header append Cache-Control "max-age=1728000, public, must-revalidate, proxy-revalidate"
    </IfModule>

    # Set Entity Tag header
    FileETag MTime Size
    </FilesMatch>
    # END Headers: Ensure client-side caching of objects

    <!-- W3 Total Cache: Page cache debug info:
    Engine: disk (enhanced)
    Key: henry-omenogor-breakthrough-experience/1138/_default_.html
    Caching: enabled
    Status: not cached
    Creation Time: 0.647s
    Header info:
    X-Powered-By: W3 Total Cache/0.8.5.2
    X-Pingback: http://www.strictlyonlinebiz.com/blog/xmlrpc.php
    Content-Type: text/html; charset=UTF-8
    X-Mobilized-By: WordPress Mobile Pack 1.2.2
    Link: <http://wp.me/pLutj-im>; rel=shortlink
    Pragma: public
    Expires: Fri, 11 Jun 2010 14:37:11 GMT
    Last-Modified: Fri, 11 Jun 2010 13:37:11 GMT
    Cache-Control: max-age=3600, public, must-revalidate, proxy-revalidate
    Vary: Cookie
    Etag: 903707fe86d6d77da9f929fdb17e8588
    -->

  9. Frederick Townes
    Member
    Posted 4 years ago #

    Can you submit a bug submission report from the support tab of the plugin?

  10. dreamwhisper
    Member
    Posted 4 years ago #

    I actually had to clear the browser cache of my main browser to eliminate this:
    Page cache:
    Caching: enabled
    Status: not cached

    The not cached status was cached in my browser because of Expires Headers I have set I guess.

  11. Frederick Townes
    Member
    Posted 4 years ago #

    That's entirely possible.

Topic Closed

This topic has been closed to new replies.

About this Topic