WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Only first page visited is cached, then needs to be refreshed (4 posts)

  1. myuption
    Member
    Posted 3 years ago #

    I just installed this on a blog and was testing, I set:

    Page Cache - disk enhanced
    Minify
    Object Cache
    DB Cache works, but kills my homepage, so I disabled it

    Now, I deleted my cookies, logged out and run a test. Got this on my homepage:

    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk (enhanced)
    Key:                _index.html
    Caching:            enabled
    Status:             cached
    Creation Time:      0.013s
    Header info:
    X-Powered-By:       PHP/5.2.14
    Last-Modified:      Thu, 09 Dec 2010 19:24:40 GMT
    Vary:               Accept-Encoding, Cookie
    Content-Encoding:   gzip
    -->

    Now, when I visit another page, the debug info says:

    <!-- W3 Total Cache: Page cache debug info:
    Engine:             disk
    Key:                w3tc_415705253a867f84a3ed8d3ebd424bbf_page_6af5488d38c93cca7265f96b14399fb5
    Caching:            enabled
    Status:             not cached
    Creation Time:      2.705s
    Header info:
    Expires:            Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control:      no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma:             no-cache
    X-Powered-By:       W3 Total Cache/0.9.1.3
    Link:               <http://www.site.com/?p=2831>; rel=shortlink
    Last-Modified:      Thu, 09 Dec 2010 19:12:48 GMT
    Vary:               Accept-Encoding, Cookie
    Content-Encoding:   gzip
    X-Pingback:         http://www.terapiaintegral.com/content/xmlrpc.php
    Content-Type:       text/html; charset=UTF-8
    -->

    Unless I click F5 to refresh, it is not cached.

    Am I doing something wrong? Or this is the normal behavior of the plugin?

    Thanks for your comments

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did you clear your browser cookies?

  3. myuption
    Member
    Posted 3 years ago #

    Sorry for the delay, yeah, I cleared cookies.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Are you still having this problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic