WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Not connecting to rackspace ?? (16 posts)

  1. onomoney
    Member
    Posted 3 years ago #

    Hi Everyone,

    Time to expose my ignorance, I have looked for a tutorial for two days now and can't seem to find an answer to possibly the most simple question.

    I am trying to configure w3tc with Rackspace Cloud, I have built the container. not a problem there.

    When I get to the next part is where my brain is frozen.

    Replace site's hostname with:
    the container # .cloudfiles.rackspacecloud.com or CNAME:

    Then next there are boxes to put different cnames

    Where do I replace "sites hostname? and with what?
    How do I configure the Cname part under that line?

    This is frustrating I have tried many combinations it has to be something real simple that I'm missing.

    I apologize for my ignorance but have found nothing so far to direct me in this part of the process. I have had W3tc forking for some time on a mirror site but feel it necessary to take full advantage of this awesome plugin.

    I truly appreciate your time.
    Brad West

  2. onomoney
    Member
    Posted 3 years ago #

    Even though I can't seem to get W3Total Cache to work there must be some on out there that can point me in the right direction.

    Is there a in-depth tutorial out there that is haven't found?

    These are my questions.

    How to configure w3tc with Rackspace Cloud

    Where do I replace "sites hostname? and with what?
    How do I configure the Cname part under that line?

    Thanks

  3. jelavich
    Member
    Posted 3 years ago #

    I have not had good luck with the rackspace cloud files accounts I have set up. Make sure there is permissions OK on the container - i had a real bear with amazon getting it to always allow public read always.

  4. onomoney
    Member
    Posted 3 years ago #

    @jelavich What are you using that does work and is geared for the small operation?

    Some how I have files that uploaded but no theme files and my theme now looks like it is running no script. Been messing with this for a week now and all I seem to be doing is burning up my time.

    Thanks for the response though, your great!

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Normally, creating the bucket using W3TC will also populate the "Replace site's hostname with" field and then simply click the "test cloud files upload" button to make sure that it works properly. Then you can move on to export your files to cloudfiles and ultimately enable CDN on the general settings tab and empty the page cache.

  6. onomoney
    Member
    Posted 3 years ago #

    Thanks for responding Frederick,

    I defiantly have the procedure down I just don't seem to be understanding the the link structure to call the files, I keep getting an error when testing.

    I tried,
    Error: Unable to resolve domain: http://c0000283.cdn2.cloudfiles.rackspacecloud.com/.

    I got specific an tried,
    Error: Unable to resolve domain: http://c0000427.cdn2.cloudfiles.rackspacecloud.com/wp-content/themes/twentyten/.

    I am assuming that red is not the desired color with the message error when testing.

    So then I give the import export a try and get these results all red.

    I am using a test site to master this first W3TC is the only plugin active on it, just so I know there is no outside interference.

    Importing into the media library.

    wp-content/uploads/2010/08/drivers.png File already exists in the media library
    wp-content/uploads/2010/08/drivers.png File already exists in the media library

    Then exporting Media library to cdn

    wp-content/uploads/2010/08/Abbotts-Limousine-Livery-Service-header-300x63.jpg Object already exists
    wp-content/uploads/2010/08/Abbotts-Limousine-Livery-Service-header-150x150.jpg Object already exists
    wp-content/uploads/2010/08/Abbotts-Limousine-Livery-Service-header.jpg Object already exists

    The issue now that I see that I am getting files to load is the Theme is loaded but is running as a no script on the background.
    http://anipalshop.com/

    Sorry I am real new at this game.

  7. onomoney
    Member
    Posted 3 years ago #

    I think I may have got it!

  8. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    You sure?

  9. onomoney
    Member
    Posted 3 years ago #

    Not absolutely sure.
    I have one question if you would.
    I am working on this site right now http://anipalinfo.com/
    My question is in the configuration area.
    Replace site's hostname with: c0000436.cdn2.cloudfiles.rackspacecloud.com
    When is says (reserve for css), (reserve for JS <head>), (reserve for JS after <body>), (reserve for JS before </body>)
    Do I just put in the replacement url like it is or is there something that should be added after?
    c0000436.cdn2.cloudfiles.rackspacecloud.com/???????/??????
    The test always seemed to come up not favorable if I added anything, but the container populated and connected the files.
    Thanks for your time

  10. onomoney
    Member
    Posted 3 years ago #

    Kind of odd the http://anipalinfo.com/ site was loading at 2.2 seconds yesterday and is now loading at, well the best I got all day was 2.9 seconds on Pingdom.

    Today I put http://fuzzywuzzyanipals.com/ on Rackspace Cloud from a self hosted situation. I know it has only been hours.

    Never mind it was taking about twice as long to load 6.5 seconds or so now I just tested it and it is loading at between 1.7 and 2.7 seconds. Respectable for all the images on the front page.

    Is there any part of W3TC that I possibly shouldn't be running with Rackspace? I have been playing with minimizing files manually and turning off the minify. Looking for anything to get that little edge, like many of you.

  11. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Do I just put in the replacement url like it is or is there something that should be added after?

    Just put the hostname you want to use there. It's showing you that some hostnames are reserved for a specific file type so you will know how many you need and how the logic works for hostname usage.

    Never mind it was taking about twice as long to load 6.5 seconds or so now I just tested it and it is loading at between 1.7 and 2.7 seconds. Respectable for all the images on the front page.

    Unfortunately, testing tools simply aren't reliable due to the nature of the internet. The point remains that you have a highly optimized setup when using a CDN for your site. Mileage will vary per test, per user, per time of day, per network, per CPU, per network card, per MTU, ad nauseam.

  12. onomoney
    Member
    Posted 3 years ago #

    Thank You for your time Frederick,

    I was just questioning if I had to add an extension to the the hostname or if you had already set the system up to do just that. Evidently you have simplified things too much for me. Awesome job!

    I understand the testing tools and their inconsistencies I have about 4 I use with various results. The bottom line is that you have created one of the most awesome tools for speeding up wordpress ever and want to thank you for not only your creation of W3TC but your great support. I just wish it was this simple for my phpbb forum site.

    Your Awesome!

  13. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I'm glad it's working for you. More to come.

  14. onomoney
    Member
    Posted 3 years ago #

    Can only imagine what other tweaks you have up your sleeve!

    Thanks Frederick!

  15. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    You're welcome.

  16. bt-chadski
    Member
    Posted 3 years ago #

    onomoney,

    This is unrelated to the thread - I was wondering which rackspace product you are running your site on? Thx. you can e-mail me at chernoff . rei at gmail.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic