WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Not caching? (11 posts)

  1. webwitch
    Member
    Posted 3 years ago #

    I have set up W3 total cache plugin and configured it but am getting this result in YSlow for the page. The css and other files seem to be caching but not the page. Anyone, have any idea what can be done?
    Thank you in advance.

    Date Tue, 29 Mar 2011 12:35:02 GMT
    Server Apache/2
    Expires Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma no-cache
    X-Pingback http://www.xxxxxxx.org.uk/xmlrpc.php
    X-Powered-By W3 Total Cache/0.9.1.3
    Vary Accept-Encoding,User-Agent
    Content-Encoding gzip
    Content-Length 7016
    Keep-Alive timeout=15, max=97
    Connection Keep-Alive
    Content-Type text/html; charset=UTF-8

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. webwitch
    Member
    Posted 3 years ago #

    I should add that I have tried to do a page debug but the code does NOT appear in the source code at the bottom - all I get is the basic "performance optimized by W3 Total Cache..."

    So that doesn't appear to be working on my site.

  3. shanepetty
    Member
    Posted 3 years ago #

    Did you run the W3 Total Cache "Compatibility Check" in the W3 Total Cache Settings? Clicked on from the Plugins area.

    After I cleared all my Reds, it worked like a charm on WP 3.1

  4. webwitch
    Member
    Posted 3 years ago #

    Hi shanepetty, thanks for your reply.

    Yes, I have already run a compatability check and contacted my web host about the two items below. They are not installed on the shared server because of security issues.
    Opcode cache: Not installed
    Memcache extension: Not installed

    There were also a few php modules that were not detected although the web host assures me that they are in fact available.

  5. shanepetty
    Member
    Posted 3 years ago #

    My site is installed on Ubuntu 10 running on a virtual server. I was having issues with the site loading extremely slow. Once I installed Alternative PHP Cache (APC), the site ran incredibly fast.

    Don't know if that is your issue, I'm relatively new to the Ubuntu Apache 2, but it sure helped. Fixing those RED variables on the compatibility check was the only thing I did to make the W3 cache work.

    Hope that helps.

  6. webwitch
    Member
    Posted 3 years ago #

    Not sure if I can change anything on the server as it is a shared server so I am hoping I can sort this another way. Thanks for your help.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    It appears another plugin is interfering with W3TC. Can you temporarily disable other plugins to see if caching starts to work?

  8. webwitch
    Member
    Posted 2 years ago #

    There appears to be a conflict with the WP Simple PayPal Shopping Cart. When this is deactivated I get a different report on YSlow

    Date Tue, 19 Jul 2011 15:55:38 GMT
    Server Apache/2
    X-Pingback http://www.afasicengland.org.uk/xmlrpc.php
    X-Powered-By W3 Total Cache/0.9.1.4b
    Vary Accept-Encoding,User-Agent
    Cache-Control max-age=3600
    Expires Tue, 19 Jul 2011 16:55:38 GMT
    Keep-Alive timeout=15, max=100
    Connection Keep-Alive
    Transfer-Encoding chunked
    Content-Type text/html; charset=UTF-8

    I really need the shopping cart so is there anything I can do to keep this running without a conflict?

    Thank you for any help.

  9. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Can you please try the latest release adn report back if there are issues?

    Also ask the plugin author how to configure either plugin to work with caching.

  10. webwitch
    Member
    Posted 2 years ago #

    Thank you for your reply.

    I have now have the latest versions of the W3 total cache and paypal shopping cart plugins. The shopping cart plugin author advised to add "cart_in_use" to the rejected cookies. I have done this and still the page cache does not work so I am at a loss to know what to do. Again, if I deactivate the cart plugin then the page cache works so there is still a conflict.

    Hopefully will find an answer to this. Any suggestions would be very, very appreciated.

    Thank you.

  11. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Can you add the plugin author to this thread please?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic