WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] No matter what, can't get past .htaccess not writeable (7 posts)

  1. eggroll
    Member
    Posted 2 years ago #

    I've read every post I can find and can't get w3 total cache to write to the .htaccess file(s). I've set the permissions temporarily to 777 on the site .htaccess file as well as the .htaccess files in the pgcache and min directories, but compatibility check still says /.htaccess not writeable.

    I've gone to the w3 total cache install page of the dashboard and cut and pasted the code it says I need into the three separate files (/.htaccess, /wp-content/w3tc/min/.htaccess, and /wp-content/w3tc/pgcache/.htaccess) but I continue to get the messages that disk enhanced page caching and browser caching aren't active and that I need to add code that I've already added.

    Since I'm in the process of moving this WordPress site from another host, it currently resides in a subdirectory of a subdirectory of a temp url at the new host (looks something like this: http://12.345.678.90/~subdir1/subdir2/), so I'm guessing that's where the problem lies, but I'm not sure how to fix it. The main mod_rewrite for WordPress is as follows:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~subdir1/subdir2/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~subdir1/subdir2/index.php [L]
    </IfModule>
    # END WordPress

    Any suggestions would be greatly appreciated.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Jolanda_
    Member
    Posted 2 years ago #

    I have a similar problem: in my case the plugin can't write to the .htaccess file either
    The .htaccess file is in a cgi-bin folder, which is in the same directory as all my wordpress files.
    Could this be the problem?
    I've tried creating another .htacces file within the wordpress directory, but that doesn't work (results in an internal server error).

    Help?

  3. Texiwill
    Member
    Posted 2 years ago #

    Hello,

    I had a similar problem, I believe it is related to ordering on how document_root is detected. If I switch to this within w3_get_document_root it now gives proper paths

    if (!empty($_SERVER['DOCUMENT_ROOT'])) {
                $document_root = w3_path($_SERVER['DOCUMENT_ROOT']);
            } elseif (!empty($_SERVER['SCRIPT_FILENAME'])) {
                $document_root = substr(w3_path($_SERVER['SCRIPT_FILENAME']), 0, -strlen(w3_path($_SERVER['PHP_SELF'])));

    I found that the SCRIPT_FILENAME method was producing /full/path/word instead of /full/path/wordpress while $_SERVER['DOCUMENT_ROOT'] always had the correct variable.

    -- Edward

  4. happysadhu
    Member
    Posted 2 years ago #

    I am having a similar problem with my WP Total Cache not being able to access my .htaccess even though the permissions are set to 777. My wordpress is installed in the root of the public_html folder. I would like to try the solution above, but I don't know where I change the code? What file do I make the the change in?

    Thanks,
    Sam

  5. happysadhu
    Member
    Posted 2 years ago #

    OK. I think I found which file and line the code is in. Please let me know if I have it right. I am still having the htaccess issue.
    The file is define.php found in wp-content/plugins/w3-total-cache/inc
    The code I changed started line 582. It now looks like this:

    function w3_get_document_root() {
        static $document_root = null;
    if ($document_root === null) {
            if (!empty($_SERVER['DOCUMENT_ROOT'])) {
                $document_root = w3_path($_SERVER['DOCUMENT_ROOT']);
            } elseif (!empty($_SERVER['SCRIPT_FILENAME'])) {
                $document_root = substr(w3_path($_SERVER['SCRIPT_FILENAME']), 0, -strlen(w3_path($_SERVER['PHP_SELF'])));
            } elseif (!empty($_SERVER['PATH_TRANSLATED'])) {
                $document_root = substr(w3_path($_SERVER['PATH_TRANSLATED']), 0, -strlen(w3_path($_SERVER['PHP_SELF'])));
            } elseif (!empty($_SERVER['DOCUMENT_ROOT'])) {
                $document_root = w3_path($_SERVER['DOCUMENT_ROOT']);
            } else {
                $document_root = w3_get_site_root();
            }
    
            $document_root = realpath($document_root);
            $document_root = w3_path($document_root);
        }
    
        return $document_root;
    }
  6. happysadhu
    Member
    Posted 2 years ago #

    I should add that I also get the error "Unable to make CloudFlare API request." when I try to change the Cloud Flare settings in WP Total Cache. I double checked the email, domain and API key--all are correct.

    I manually changed the htaccess file in the root of my site folder, but still having both Cloud Flare and caching issues. The htaccess file is not recognized? (I am using WordPress 3.3 with a Bluehost shared hosting account)

    The following is my htaccess file:

    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /category/blog/
        RewriteRule ^(.*\/)?w3tc_rewrite_test$ $1?w3tc_rewrite_test=1 [L]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=W3TC_ENC:_gzip]
        RewriteCond %{REQUEST_METHOD} !=POST
        RewriteCond %{QUERY_STRING} =""
        RewriteCond %{HTTP_HOST} =www.acupunctureclinicvictoriabc.ca
        RewriteCond %{REQUEST_URI} \/$ [OR]
        RewriteCond %{REQUEST_URI} (sitemap(_index)?\.xml(\.gz)?|[a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?) [NC]
        RewriteCond %{REQUEST_URI} !(\/wp-admin\/|\/xmlrpc.php|\/wp-(app|cron|login|register|mail)\.php|\/feed\/|wp-.*\.php|index\.php) [NC,OR]
        RewriteCond %{REQUEST_URI} (wp-comments-popup\.php|wp-links-opml\.php|wp-locations\.php) [NC]
        RewriteCond %{HTTP_COOKIE} !(comment_author|wp-postpass|wordpress_\[a-f0-9\]\+|wordpress_logged_in) [NC]
        RewriteCond %{HTTP_USER_AGENT} !(W3\ Total\ Cache/0\.9\.2\.4) [NC]
        RewriteCond "%{DOCUMENT_ROOT}/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" -f
        RewriteRule .* "/wp-content/w3tc/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]
    </IfModule>
    # END W3TC Page Cache core
    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            BrowserMatch ^Mozilla/4 gzip-only-text/html
            BrowserMatch ^Mozilla/4\.0[678] no-gzip
            BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
            BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
        </IfModule>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
        </IfModule>
        <IfModule mod_filter.c>
            AddOutputFilterByType DEFLATE text/css application/x-javascript text/x-component text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon
        </IfModule>
    </IfModule>
    <FilesMatch "\.(css|js|htc|CSS|JS|HTC)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/0.9.2.4"
        </IfModule>
    </FilesMatch>
    <FilesMatch "\.(html|htm|rtf|rtx|svg|svgz|txt|xsd|xsl|xml|HTML|HTM|RTF|RTX|SVG|SVGZ|TXT|XSD|XSL|XML)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/0.9.2.4"
        </IfModule>
    </FilesMatch>
    <FilesMatch "\.(asf|asx|wax|wmv|wmx|avi|bmp|class|divx|doc|docx|eot|exe|gif|gz|gzip|ico|jpg|jpeg|jpe|mdb|mid|midi|mov|qt|mp3|m4a|mp4|m4v|mpeg|mpg|mpe|mpp|otf|odb|odc|odf|odg|odp|ods|odt|ogg|pdf|png|pot|pps|ppt|pptx|ra|ram|svg|svgz|swf|tar|tif|tiff|ttf|ttc|wav|wma|wri|xla|xls|xlsx|xlt|xlw|zip|ASF|ASX|WAX|WMV|WMX|AVI|BMP|CLASS|DIVX|DOC|DOCX|EOT|EXE|GIF|GZ|GZIP|ICO|JPG|JPEG|JPE|MDB|MID|MIDI|MOV|QT|MP3|M4A|MP4|M4V|MPEG|MPG|MPE|MPP|OTF|ODB|ODC|ODF|ODG|ODP|ODS|ODT|OGG|PDF|PNG|POT|PPS|PPT|PPTX|RA|RAM|SVG|SVGZ|SWF|TAR|TIF|TIFF|TTF|TTC|WAV|WMA|WRI|XLA|XLS|XLSX|XLT|XLW|ZIP)$">
        FileETag None
        <IfModule mod_headers.c>
             Header set X-Powered-By "W3 Total Cache/0.9.2.4"
        </IfModule>
    </FilesMatch>
    # END W3TC Browser Cache
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  7. cyonite
    Member
    Posted 2 years ago #

    You can try and edit the .htaccess files manually by following the instructions on the Install page on the plugin pages.

    If you still have problems you can file a bug submission form on the Support page in the plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic