WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
New version, something better, but minify STILL DOES NOT work for me! (33 posts)

  1. the_loop
    Member
    Posted 4 years ago #

    Hi,
    I sent a bug report about this yet, for a previous version...
    Now, luckily, works page caching with disk optimized, previously only with disk.

    But minyfy doesn't work at all.

    No problems for html minifying, but for css and js give always an error 400; simply, the plugin does not create the requested files, for example firebug says:
    "NetworkError: 404 Not Found - http://spingitoridicavalieri.webatu.com/wp-content/w3tc/min/3f5a17/default.include-nb.233486005.js "
    and, yes, the folder w3tc/min just contains some ".id" files, like default.include-nb.js.id , inside a folder called 3f5a17 (for my theme, I argue)

    The folder is of course writable (w3tc always creates .id files), and I surely disabled other plugins I'm forced to use for optimization (autoptimize, head cleaner, and still the do not fully work...)

    Debug:

    <!-- W3 Total Cache: Minify debug info:
    Engine:             disk
    Theme:              3f5a17
    Template:           index
    JavaScript info:
       Location     |    Last modified    |         Size | Path
     include-body   | 2010-05-20 14:18:30 |          193 | /home/MYUSERNAME/public_html/wp-content/qtip_js/qtip.js
      include-nb    | 2010-05-13 23:35:41 |        14083 | /home/MYUSERNAME/public_html/wp-content/plugins/google-ajax-translation/jquery.translate-1.4.1.min.js
    -->

    Well, now, thits is my compatibility:

    Server Modules & Resources:
    PHP Version: 5.2.10
    PHP Timezone: Not set
    Web Server: Apache
    FTP functions: OK (required for Self-hosted (FTP) CDN support)
    Multibyte String support: OK (required for Rackspace Cloud Files support)
    cURL extension: OK (required for Amazon S3 support)
    zlib extension: OK (required for compression support)
    Opcode cache: Not installed
    Memcache extension: Not installed
    Mime type detection: Not installed
    Hash function: hash (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: On: /home/:/usr/lib/php:/tmp
    zlib output compression: Off
    mod_mime: Not detected
    mod_expires: Not detected
    mod_deflate / mod_gzip: Not detected
    mod_headers: Not detected
    mod_env: Not detected
    mod_setenvif: Not detected
    mod_rewrite: Not detected
    WordPress Resources
    /home/MYUSERNAME/public_html/wp-content: Not write-able
    Not write-able
    
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: Off

    And, ops, my site is http://spingitoridicavalieri.webatu.com .

    Well, I love this plugin, my site is an amatorial one, but the same I really really hope to resolve this issue, just for sake of knowledge :D

    Thanks, bye

  2. mistercyril
    Member
    Posted 4 years ago #

    Exact same problem here!

  3. Frederick Townes
    Member
    Plugin Author

    Posted 4 years ago #

    Using apache web server? Apache isn't using the .htaccess file in wp-content/w3tc/min/. Check your web server configuration or disable URL rewriting for minify.

  4. mistercyril
    Member
    Posted 4 years ago #

    Hello,
    I noticed this in the "compatibility check" :

    WordPress Resources

    /wordpress_mu_292_php/wp-content: Write-able
    /wordpress_mu_292_php/.htaccess Write-able
    Not write-able
    Uploads directory: Write-able
    WP_CACHE define: OK
    Fancy permalinks: OK
    Network mode: On
    VHOST mode: On

    Notice how the third line says "not write-able" but doesn't specify what this message is referring to.

    Could this be an issue?

  5. the_loop
    Member
    Posted 4 years ago #

    Hey Frederick, what should I check about server configuration? Of course I do not have control on it, it's a public hosting (000webhost... yes, worse one :D).

    About rewriting, I tried yet, I get a different error:
    "NetworkError: 400 Bad Request - http://spingitoridicavalieri.webatu.com/wp-content/w3tc/min/index.php?tt=3f5a17&gg=default&g=include&t=js "

    Thanks, bye!

  6. the_loop
    Member
    Posted 4 years ago #

    Ah, was forgetting, I've the log files fulled by this lines:

    [26-Jul-2010 16:08:44] PHP Warning:  realpath() [<a href='function.realpath'>function.realpath</a>]: open_basedir restriction in effect. File(/usr/local/apache/htdocs) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/MYUSER/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 715
    
    [26-Jul-2010 16:08:45] PHP Warning:  realpath() [<a href='function.realpath'>function.realpath</a>]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/MYUSER/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 749
    
    [26-Jul-2010 17:12:46] PHP Warning:  Division by zero in /home/MYUSER/public_html/wp-content/plugins/w3-total-cache/lib/W3/PgCache.php on line 436

    The most of them are the "open_basedir restriction" type.

    I hope it means something, and that there's a way to cure this verbosity! :D

  7. the_loop
    Member
    Posted 4 years ago #

    UP...

  8. theorib
    Member
    Posted 4 years ago #

    I have the very same problem, I submitted a but report form the support tab but still couldn't find a workaround for the minify issue in my server.

  9. the_loop
    Member
    Posted 4 years ago #

    At least should be useful knowing wuat is the problem, does this feature, it's an apache setting, a misconfiguration, a missing module?
    So we could ask something to our hosters, change servers pr simply give up! :D

  10. Azrael-sub7
    Member
    Posted 4 years ago #

    I think the problem is with the paths , there are some functions returning paths to some files and folders in the plugin , but on openbase_dir restriction those function aren't returning the paths correctly . So maybe the author should add support for hosts with openbase_dir restriction , i think , this can be done by making additional fields in administration were user must put the paths manually , there maybe other ways i don't know for sure but i think support for hosts with openbase_dir should be added .

  11. almarma
    Member
    Posted 3 years ago #

    Hi,
    I also have my websites hosted in 000webhosting and also run the same problem. I cannot use this plugin, and I really miss it :(. I tried with other called Wp Super Cache, and after enabling it, I tried Google Firefox Plugin to check my site. It was in 66/100 score, and after it, the score was the same. With Total Cache in my local testing site, I improved the score to 77/100!!!! I hope you can find a solution. Thank you.

  12. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @the_loop I would love to debug on someone's server as I'd obviously like to resolve this case. :)

  13. the_loop
    Member
    Posted 3 years ago #

    Well I definitely would love it, what can I do to help you debug?

  14. the_loop
    Member
    Posted 3 years ago #

    I notice you a new error:

    [04-Aug-2010 07:33:46] PHP Warning: Division by zero in /home/XXXXXXX/public_html/wp-content/plugins/w3-total-cache/lib/W3/PgCache.php on line 436
    That line says:
    $comments_pages_number = ceil($comments_number / $comments_per_page);

    I suppose that if there's no comments it rightly divides by zero?

  15. almarma
    Member
    Posted 3 years ago #

    Frederik, I would also love to help you. Tell me what to do, and I'll do it (If I know how, of course ;) )

  16. theorib
    Member
    Posted 3 years ago #

    Hey frederick,
    I can give you access to one of my servers were I have this issue to see if we can solve it. what can we do?

  17. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I need bug submission forms from you to take any next steps.

  18. almarma
    Member
    Posted 3 years ago #

    I need bug submission forms from you to take any next steps.

    Where? How? Here? Or are you answering to Theorib? Sorry and thank you

  19. the_loop
    Member
    Posted 3 years ago #

    Ok, I'll send one ASAP.
    My previous one you didn't recieved was about an old version and could not be sent successfully due to a mail sending trouble on the server I'm hosted on.
    Thanks and bye!

  20. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Ok, then you can send an email.

  21. giladpn
    Member
    Posted 3 years ago #

    Frederick, is this related to the problem I reported where I cannot enable minify for CSS, though minify for other things does work?

    (you'll recall you were working on this before your vacation)

    If so - I sent a bug report and gave you access. You still have that access! You can debug on my system.

  22. Azrael-sub7
    Member
    Posted 3 years ago #

    Nothing new on the issue ?

  23. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Frederick, is this related to the problem I reported where I cannot enable minify for CSS, though minify for other things does work?

    A minify bug with http and https minify was found and is being resolved. Other than that, no @Azrael-sub7 nothing new here.

  24. Azrael-sub7
    Member
    Posted 3 years ago #

    @Frederick Townes
    I tested the new version on a server that has open_basedir enabled and now everything works well . Minify has no problem now , but i found a small bug on the server i tested .
    Is not affecting the plugin but it is a little annoying , after i deploy i get "Preview settings successfully deployed." but also get "Preview mode is active: Changed settings will not take effect until you or preview mode. any changed settings (without deploying), or make additional changes. " , although the plugin works perfectly it somehow shows in settings that is not deployed . Have you any clue why this might happen ?
    And if is not to much to ask you said before that in a new version you will enable partial caching ( meaning some parts of a page can remain dynamic ) , can i ask if you plan this feature in future versions ?

  25. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Try the development version to see if that still happens. Fragment caching is already available, check the usage section of the FAQ for details.

  26. Azrael-sub7
    Member
    Posted 3 years ago #

    Thanks a lot for support i didn't read the new FAQ sorry about that .
    The problem was that the w3-total-cache-config-preview.php could not be deleted when unlink , a permission problem from server .
    Anyway anybody who uses 000webost must know that the timezone is not set , but it can be set from .htaccess with the directive " php_value date.timezone Europe/Bucharest " ( change Bucharest with other available location check php manual ) .
    Thanks once again now is everything ok .

  27. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Ok great.

  28. the_loop
    Member
    Posted 3 years ago #

    Azrael, great tip for timezone, thanks!
    What about open_basedir on 000webhost?

    @Fredrick: i still didn't send you the bug report :D

  29. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @the_loop, so the issue is resolved? open_basedir restrictions shouldn't be related.

  30. Azrael-sub7
    Member
    Posted 3 years ago #

    Today on 7 september i updated the plugin to version 0.9.1.2 . But again after updated i encountered this warning message :

    Warning: realpath() [function.realpath]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/:/usr/lib/php:/tmp) in /home/****/public_html/wp-content/plugins/w3-total-cache/inc/define.php on line 749

    ( and same error on line 715 )
    And i made a clear update , meaning that i deleted all old files and still the same warning that causes minify not to work , so i was forced to downgrade to 0.9.1.1 that works with open_basedir set , including on 000webhost hosts that i have tested . So the past bug has return in 0.9.1.2 . Please fix if possible .

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic