WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Need help with this (BIG) problem (6 posts)

  1. Bruno Rosa
    Member
    Posted 3 years ago #

    Im sorry, probably this problem was already posted here... but I cant seem to find the answers to it...

    I recently had to install W3 Total Cache on my wordpress instalation, recomended by my host provider because there was some overloading problem and they shut down my website.... so i installed this and they configured it... since then, every time I update my website (wich is every day, and a lot of time a day) and when I update files from my template, I always have to wait a LOT until I can see the changes in the website...

    I mean, this is awful, because since then it became impossible to perform changes on the template, and im a bit affraid of disabling to perform these changes and it has some overload and they shut down the website again...

    So... is there any configuration Im missing that can resolve this problem?

    Thanks!!

  2. a1wsn
    Member
    Posted 3 years ago #

    You don't need to wait until the cache clears itself, you can clear it manually and so immediately see the results of the changes you've made. To do this, go to your Admin, go to the Performance settings, then to 'Page Cache Settings' and click the 'empty cache' button. You will then see the results of your template changes.

    If you are the only user for your site (i.e. your visitors do not usually log in) then it's even easier to just go to the 'Page Cache Settings' and select the option 'Don't cache pages for logged in users' (and then use the 'Save Changes' button) and then so long as you are logged in you will always see the most current version of the site including any template changes you've made, but other regular visitors will still see the old version until the cache refreshes itself at some time in the future.

    Hope this helps :)

  3. Bruno Rosa
    Member
    Posted 3 years ago #

    Hey! Thanks for your answer!

    The problem is exactly that... I have that option selected, and even when Im logged in, it wont refresh itself... so.... the "Dont cache for logged users" isnt working correctly i guess... dont know if this is a known bug, or if there is any other option that can be incompatible with this option....

  4. 72strokes
    Member
    Posted 3 years ago #

    Do you have browser caching enabled? Have you cleared your local browser cache?

  5. a1wsn
    Member
    Posted 3 years ago #

    I have browser caching enabled and I have never needed to clear my browser cache to see the page changes so long as I'm logged in.

    How about the first option that I described? When you click on the 'empty cache' button, surely that works? If not, how about the 'empty all caches' button on the 'General Settings' page?

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Did you ask your host about this issue? It seems like it might take some time for the network-based file system to reflect the changes you're making to your W3TC settings which are saved to the disk.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic