WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] missing } after property list (2 posts)

  1. Kristina
    Member
    Posted 4 years ago #

    First of all, let me say thank you for a great plugin. It's nice not to have to use 3x plugins for optimization when you can use just one!

    I'm having a significant series of problems getting this to work (and it's always to do with minification--WP-Minify did the same to me until I gave up and uninstalled it). I'm getting a lot of error messages in IE and Firebug. Here's what I've got:
    In IE:

    Webpage error details
    
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; Alexa Toolbar)
    Timestamp: Mon, 18 Jan 2010 18:14:24 UTC
    
    Message: Expected '}'
    Line: 1
    Char: 44374
    Code: 0
    URI: http://www.prettyshinysparkly.com/wp-content/w3tc/min/default.include-footer.js

    In Firebug:

    a is undefined
    a;a=fcf+"/friendconnect/lightbox"}var s=...his.f);a=fc5.v(a);return a.viewParams};\n
    friendconnect.js (line 704)
    missing } after property list
    [Break on this error] **":M.accepts._default)}catch(S){}if(M.b...n(X){if(J.readyState==0){if(P){clearIntedefault
    default.include-footer.js (line 1)

    I'm not sure why these messages are showing footer.js in line 1. Shouldn't it be in the footer? Anyway, here is what I have minifying:

    http://www.prettyshinysparkly.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.0.2
    http://www.prettyshinysparkly.com/wp-content/plugins/pixopoint-menu/scripts/superfish_settings.js.php?ver=1.0
    http://www.prettyshinysparkly.com/wp-includes/js/comment-reply.js?ver=20090102
    http://www.prettyshinysparkly.com/wp-includes/js/jquery/jquery.js?ver=1.3.2
    http://www.prettyshinysparkly.com/wp-content/plugins/pixopoint-menu/scripts/superfish.js?ver=1.4.8
    http://www.prettyshinysparkly.com/wp-content/plugins/pixopoint-menu/scripts/hoverIntent.js.php?ver=r5
    http://www.prettyshinysparkly.com/wp-includes/js/jquery/jquery.form.js?ver=2.02m
    http://www.google-analytics.com/ga.js

    All with "Embed in: Footer" enabled.

    As a test, I turned off removing comments and linebreaks in the JS minify section, and now I get this error:

    jQuery is not defined
    jQuery(document).ready(function(){jQuery...href=a.attr('href');if(href==undefined)\n

    again in default.include-footer.js (line 1)
    Thanks for your help!

  2. andtokyo
    Member
    Posted 3 years ago #

    3 errors from IE

    Message: Expected '}'
    Line: 1
    Char: 57989
    Code: 0
    URI: http://mydomain.com/wp-content/w3tc/min/dbeaeb/default.include-body.1156305633.js

    &
    Message: Object expected
    Line: 1
    Char: 1
    Code: 0
    URI: http://mydomain.com/thirdname/

    &
    Message: Object expected
    Line: 1
    Char: 1
    Code: 0
    URI: http://mydomain.com/thirdname/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.