WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Minify settings: Added JS and CSS files aren't getting saved (7 posts)

  1. shortster
    Member
    Posted 3 years ago #

    After moving my wordpress from the test folder to my main folder, and doing a find/replace of the domainname in the database export, some of my w3 total cache settings were gone.

    The most annoying issue I still have at the moment is that I cannot add JS and CSS files to the minify settings. When I click save and the page reloads, the added files are gone.

    I suspect it's a permissions issue again, but I've double checked, and tried even putting a lot more folders to 777, but no luck.

    How can I let the minify setting get saved again?
    And when moving a wordpress site to another folder or domain. Is it save to do a find/replace in de database export? Or will this mess up some settings arrays maybe?

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    How can I let the minify setting get saved again?

    You should deactivate the plugin and re-activate it and see what notifications appear. You can then manually edit file paths and you will likely need to make sure your uploads directory path is correct in your database now because W3TC checks that.

    And when moving a wordpress site to another folder or domain. Is it save to do a find/replace in de database export? Or will this mess up some settings arrays maybe?

    No it's not so simple, you'll need to do the above and no doubt check numerous other things in your site outside of W3TC.

  3. shortster
    Member
    Posted 3 years ago #

    I tried de/reactivating and even re-installing. All the folders and files seem to have the right permissions because I don't get any more notifications.

    The uploads directory in the wordpress admin Settings > Media is empty, using the default wp-content/uploads directory (which has 777). If this is the uploads directory you mean.

    Any other suggestions?

  4. Catherine
    Member
    Posted 3 years ago #

    my Minify settings using the Help Wizard are not saving, either.

  5. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Can't guess. This is very strange. Only a bug submission form will allow me to investigate.

  6. shortster
    Member
    Posted 3 years ago #

    Hi Frederick, I submitted a bug. Thank you for your time.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    This is fixed in the development version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic