WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Minify Doesnt work and maxCDN dont allow to select for minified files (6 posts)

  1. soamz
    Member
    Posted 3 years ago #

    Hi..
    My site is http://tinyurl.com/29s3yr9
    Im using w3 Total Cache and maxCDN.

    Ok one thing is proved that, the MINIFY in w3 Total Cache doesnt work.

    So, I had install WP MINIFY to get my css js minified.
    Anyways.

    In CDN setting page, there is an option,
    "Host minified CSS and JS files"

    But Im not able to enable that option. It just doesnt allow.

    I see, all of my site images are coming from CDN , but my minified JS and CSS files are not still coming from the web host.

    I need to get it to work, so that minified files also comes from CDN.

  2. soamz
    Member
    Posted 3 years ago #

    Another question..
    All the images which are coming from CSS are not with CDN, but from server.

    Also, let me know, how to get it to the CDN .

  3. netdna-sgonzalez
    Member
    Posted 3 years ago #

    Hi,

    I would first start by taking a step back and looking over all of the W3 Total Cache settings to make sure then on the General Settings tab that you have browswer caching, minification, db and CDN Settings turned on and enabled. For CDN Settings you want to use a Mirror Zone (NetDNA/MAxCDN)

    For reference we have a great wiki article at
    http://wiki.netdna.com/Implementation/Wordpress

    That will help walk you through the W3 Total Cache implementation.

    Another piece of advice would be not to use multiple plugins that could potentially conflict with each other. ie don't use W3TC and WP Super Cache, or W3TC and WP Minify. When the .htaccess files and other WordpRess config files are modified in realtime you will end up with conflicts.

    Before adding the MaxCDN temporary url or custom domain record into the hostname field under CDN Settings always verify that it is working by testing a css file or image file by going to http://zonename.alias.netdna-cdn.com/filename Once you have confirmed that piece works then you can add the hostname into the plugin for it to start to rewrite the urls on the fly. You should also make sure that your plugin is is Live Mode and not Demo mode when your viewing your html source code after activation.

    If you have any further questions don't hesitate to email us at support (at) netdna (dot) come or use our Live Chat service 24/7

  4. soamz
    Member
    Posted 3 years ago #

    Ok, WP Minify plugin has been removed.

    Im still not able to get the CSS, JS files minified and nor the option for CDN to get selected for minified files.

    Here are the screenshots of my settings,

    http://mulimagehost.com/image-DC72_4D4A45F9.jpg

    http://mulimagehost.com/image-67FA_4D4A45F9.jpg

    http://mulimagehost.com/image-9D5F_4D4A45F9.jpg

  5. netdna-sgonzalez
    Member
    Posted 3 years ago #

    Well first looking at your General Settings you are still in preview mode so no live changes are being made to your site. You need to hit "disable" in the preview mode section. Be sure to clear cache after this to make sure everything is working.

    On the minify settings tab I would make sure you have stuff checked to the js and css files are actually combind.

    In the CDN Settings sections you should provide an api user id and key so you can purge cache remotely from the plugin. You can add this API user inside your CDN Control Panel under Manage Account -> API -> Create User

    Once the files are actually minified you can then check host minified files on the CDN.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    @soamz any other questions?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic