WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Minify Bug in Internet Explorer (14 posts)

  1. kylen20
    Member
    Posted 3 years ago #

    Hi

    I've just finished my new site and was testing it in different browsers only to discover that it wasn't displaying correctly in IE.

    After lots of playing around disabling different plugins I discover that it was W3 Total Cache that was causing the problem. I've now disabled the minify element and the site is displaying correctly now.

    If I re-enable it the problem recurs, I've tried it on both the auto and manual setting and it's the same for both. My site displays correctly with minify enabled in Chrome and Firefox 3.6, so it would seem the problem is isolated to IE.

    The problem primarily effects the cufon fonts - some don't display properly; the right sidebar widget - this displays the widgets below each other rather than being able to switch between them using the 'more' button; and center text display on sub-pages and the blog - the height is reduced to about the same height as the sidebar widgets, rather than being the full screen height.

    http://www.adventurebeyond.net

    It's currently disabled so the site works correctly, but I can temporarily re-enable it if you need to to do so to be able to investigate.

    Thanks, Kyle

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. smajeed
    Member
    Posted 3 years ago #

    I have come across the same problem - using the latest version of this plugin (0.9.2.2) and it breaks the theme/pages/layout in all versions of IE because of the Minify issue... when it is set to anything other than 'default' minify options...

    Firefox/Safari/Chrome etc are all fine but IE gives a Javascript Error when the Minify function is enabled.

    Works when it is set to default minify so done that for now.

    Can see others have reported similar issues... any idea on if a fix is being worked on or coming soon?

  3. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Are you guys having this issue with the latest release?

  4. smajeed
    Member
    Posted 3 years ago #

    Yep, same problem - if you use any minify option other than default it completely breaks the site in IE - fine in other browsers...

    Just get no styles applying to the site at all so it all on a white background with content/images everywhere....

  5. javierrebelde
    Member
    Posted 3 years ago #

    Hi,

    I have been checking this discussion every now and then waiting for a solution too, I have exactly the same problem and I am using the latest version too.

  6. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    Anyone still having this issue, please submit a bug submission form from the support tab of the plugin please so I can investigate the case.

  7. scottdaris
    Member
    Posted 2 years ago #

    I don't know if this applies, but see my post about automatic minifying errors:
    http://wordpress.org/support/topic/plugin-w3-total-cache-important-parsing-found-with-automatic-minify
    (btw, I meant to say *Important* parsing error found with automatic minify)
    In the minifying process, incorrect .js code was generated. You'll see what I mean in my post. I also had tons of problems in IE, too. Good luck!

  8. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    If you've been using W3TC for a long time the user agent groups have some updates that you can get by backing up your settings and then doing a settings reset and restoring settings you customized.

  9. javierrebelde
    Member
    Posted 2 years ago #

    Hi,

    Thanks I did that but I still have the same problem. I am using version 09.2.4 and I can't use minify if I turn it on something go wrrong and some fronts dont work in internet explorer and some java script does not work in any browser.

  10. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    You'll need to be more specific about what specifically is breaking and what your settings are. Can you give more detail?

  11. javierrebelde
    Member
    Posted 2 years ago #

    Hi,

    The plugin have an area or option to exclude the js or css I dont want to minify? maybe with this I can exclude the one is giving me the problem

  12. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    The next release will have that, for now manual mode allows you to specify what is included only.

  13. i.macdonald
    Member
    Posted 2 years ago #

    I found that using the HTML Tidy for HTML minification broke all my IE rendering. Using the "Default" built in minify options resolved my IE problems. I noticed that HTML Tidy was actually purging some of the comments-in-code. Even with HTML Tidy selected, and unchecking the comment functions it broke IE (though I could not tell what the root cause was from view source in this particular setup). Bottom line is that I could not make W3TC work with HTML Tidy selected, and minification enabled.

  14. Dave
    Member
    Posted 2 years ago #

    Good spot i.macdonald! I managed to put it down to the commenting being screwed up - but couldn't pinpoint it.
    This does the trick though.

    Hopefully chrome passing IE as the most used browser might make ie pull its sock up!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic