WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Minified css and js Version # (4 posts)

  1. Virendar
    Member
    Posted 3 years ago #

    I'm using W3 Total Cache version 0.8.5.2

    I understand that I can upgrade to latest version and have my problem fixed, but I feel 0.8.5.2 works best on my site. The newer versions don't work well.

    My problem :

    In the Minify settings, I have set "Maximum lifetime of cache objects" to 30 days or so.

    So most of my visitors have already cached
    "..../w3tc/min/default.include.css"

    Now, I made a change to my .css and refreshed everything, but since most people have already cached the above css file (and file name has not changed in anyway) their browser won't bother to update it for up to 30 days.

    How can I add the version number at the end, example:
    "w3tc/min/default.include.css?ver=04082010"

    (version representing the date it was last modified or something)

    This will force browsers to update the minified .css and .js

    Thanks!!

    ( On a side note ** Even though i get the new minified URLS working and in my page source, if i actually go to the direct w3tc/min/ I don't see any files there O_O is that how it's suppose to be? Well it's not a problem since everything is working fine...*** )

  2. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    I would actually love to know what "doesn't work" now because older versions are no supported and are missing hundreds of fixes, including this issue you've described. So I'd be interested to see what is mis-behaving on your server.

  3. Virendar
    Member
    Posted 3 years ago #

    Well I don't remember all the bugs, but one of the major ones was when I clear all Cache my apache crashes, and I have to manually restart it in SSH.

    I use apc

    This doesn't happen with the current version I am using.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    Ok, well the latest version doesn't have the issue you describe in your first post. If there are other issues please advise.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic