WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] Migrated to another server; now can't activate (3 posts)

  1. KeithAdv
    Member
    Posted 4 years ago #

    So, I migrated my WordPress site to a new server.

    I did it this way--got the new account, used Fantastico to create a fresh WP installation. Backed up my old-site database and imported it into the new one. FTP'ed my theme into place. Then I FTP'ed all the plugins from my old wp-content/plugins directory to my new one.

    (I must be dumb--I thought all the site images are in the database file but I seemed to be wrong. I had to copy wp-content/uploads over, too.)

    Everything made it 100%, all other plugins are fine, and it took no time at all. It was almost too easy....

    So, the gotcha is that no matter how I try, W3 Total Cache won't activate. It installs just fine. What's weird is the error message it's giving me doesn't make sense. It's telling me I need to chmod 777 my wp-content directory but the directory path it lists is the one on MY OLD installation:

    chmod 777 /home/(Old main folder)/public_html/(mysite)/wp-content

    On my new server the path is nearly the same except the main folder has a different name.

    I have 777'd myself silly, deleted "w3-total-cache-config.php" a gazillion times, along with the "w3-total-cache" in the plugins directory.

    Anyone got any ideas?

    Thank you!

  2. KeithAdv
    Member
    Posted 4 years ago #

    Update. OK, it's not W3 Total Cache. The problem is actually bigger. I just tried to upload an image from the "Edit Post" page in WP and I got this error message:

    Unable to create directory /home/(Old main folder)/public_html/(mysite)/wp-content/uploads/2010/03. Is its parent directory writable by the server?

    So, even though I created a fresh installation, something seems to have copied over somewhere that's causing several aspects of my site to want the previous directory.

    All ideas cheerfully accepted.

  3. KeithAdv
    Member
    Posted 4 years ago #

    And...we're done.

    I had hardcoded my old path into "path for uploading files" box in WP Miscellaneous settings. As soon as I changed that to the new site, everything was hunky dory, W3 Total Cache included.

    Thanks for playing, everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.