WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] Memcached server localhost:11211 is not running problem me too (4 posts)

  1. macaro
    Member
    Posted 4 years ago #

    Hi Frederick,.

    now I use WordPress 2.8.5 on CentOS 5.3 httpd from CentOS repository. php & other php default rpm from utterramblings repository.

    rpm -qa php php-pear php-devel httpd-devel
    php-devel-5.2.11-jason.1
    httpd-devel-2.2.3-31.el5.centos
    php-pear-1.7.2-2.jason.1
    php-5.2.11-jason.1

    pecl list
    Installed packages, channel pecl.php.net:
    =========================================
    Package Version State
    APC 3.0.19 stable
    memcache 2.2.5 stable

    libevent 1.4.2 installed by source.

    ldconfig -v | grep libevent
    ldconfig: Path `/usr/local/lib' given more than once
    libevent-1.4.so.2 -> libevent.so
    libevent_core-1.4.so.2 -> libevent_core.so
    libevent_extra-1.4.so.2 -> libevent_extra.so
    libevent-1.1a.so.1 -> libevent-1.1a.so.1.0.2

    Memcached installed 1.4.0 by source.The problem is not in Memcached.

    telnet localhost 11211
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    set foo 0 0 3
    bar
    STORED
    get foo
    VALUE foo 0 3
    bar
    END
    version
    VERSION 1.4.0
    quit
    Connection closed by foreign host.

    I'm not understood. why "Database caching is not available. Memcached server localhost:11211 is not running or is non-responsive." error display for me

    What should I do? I want the suggestion. please help me..

  2. macaro
    Member
    Posted 4 years ago #

    It has forgotten to write. I'm using dedicated server.

    IPTABLES setting
    iptables -P INPUT DROP
    iptables -P OUTPUT ACCEPT
    iptables -P FORWARD DROP

    #loopback
    iptables -A INPUT -i lo -j ACCEPT
    iptables -A OUTPUT -o lo -j ACCEPT

    # all interface 11211(memcached open)
    iptables -A INPUT -p tcp --dport 11211 -j ACCEPT

  3. macaro
    Member
    Posted 4 years ago #

    Sorry Frederick,.

    It self-solved it Problem. This problem because of SELinux.

    When "localhost:11211 is not running~" message are displayed, it is possible to solve it by the following method if the error of SELinux is displayed in/var/log/message.

    # getsebool httpd_can_network_connect
    httpd_can_network_connect --> off

    if "httpd_can_network_connect --> off" then
    # setsebool -P httpd_can_network_connect 1
    # getsebool httpd_can_network_connect
    httpd_can_network_connect --> on

    Method of settlement in Japanese
    http://jinkai.macaro.net/?p=179

  4. Frederick Townes
    Member
    Posted 4 years ago #

    Great! Thanks for the input.

Topic Closed

This topic has been closed to new replies.

About this Topic