WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: W3 Total Cache] Log-in/log-out problem with Buddypress (13 posts)

  1. notpoppy
    Member
    Posted 2 years ago #

    I have W3 Total Cache 0.9.2.3 installed on WordPress 3.2.1 with Buddypress 1.2.9.

    The three seem to work happily together with almost no problems at all, except for one:

    When a user logs in or logs out, their changed state is not always reflected on the page - i.e., it shows them as still being logged in when they have just logged out, and vice-versa.

    The problem goes away if I disable page caching in W3TC but I’m not sure this is a satisfactory solution as the performance benefit of caching the pages is lost. Clearing cookies also has no effect on the problem.

    I have “Don’t cache pages for logged in users” selected.

    I have tried disabling all other plugins and using the default Buddypress theme, but the problem remains.

    This problem is also described in the Buddypress support forums where another user is experiencing the same problem:

    http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/w3-total-cache-and-buddypress-log-out-issues/

    And I have submitted a bug report via W3TC.

    Can anyone suggest a solution?

  2. Luciano Passuello
    Member
    Posted 2 years ago #

    For the record, I have the same problem here.

  3. notpoppy
    Member
    Posted 2 years ago #

    I've upgraded to W3 Total Cache 0.9.2.4, which has recently become available, and this seems to have fixed the problem.

    I'm just giving it a cautious thumbs-up for now because it was an intermittent problem before and maybe I've just been lucky. But so far, so good.

  4. Frederick Townes
    Member
    Posted 2 years ago #

    Ok great, @notpoppy, can you please mark this issue as resolved?

  5. notpoppy
    Member
    Posted 2 years ago #

    Done and done.

  6. Matt
    Member
    Posted 2 years ago #

    I'm having this same issue with the latest versions of all 3:

    WP 3.2.1
    BuddyPress 1.5.1
    W3TC 0.9.2.4

    Any ideas?

  7. Frederick Townes
    Member
    Posted 2 years ago #

    @mwbarker, are you still having this issue?

  8. cajunman4life
    Member
    Posted 2 years ago #

    I'm having this issue.

    WP 3.3.1
    W3TC 0.9.2.4
    No buddypress though.

  9. Matt
    Member
    Posted 2 years ago #

    Sorry for getting back so late, but yes, the problem still exists. Just deployed another BuddyPress site with W3TC and the admin bar still shows up once you log out - but only when W3TC is activated.

  10. Will
    Member
    Posted 2 years ago #

    Hi guys, I'm having the same issue here.

    I'm using WP 3.3.1 + BP 1.5.2 + W3TC 0.9.2.4.

  11. b1gft
    Member
    Posted 2 years ago #

    I am having the same problem, will this happen with members as well.

  12. b1gft
    Member
    Posted 2 years ago #

    I think this has to be marked on resolved. Its misleading

  13. Frederick Townes
    Member
    Posted 1 year ago #

    I think this issue is nailed in the forthcoming release.

Topic Closed

This topic has been closed to new replies.

About this Topic