WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: W3 Total Cache] JQuery conflicts when added to minify (6 posts)

  1. dustin999
    Member
    Posted 3 years ago #

    Are there any recommendations about how to handle the jquery library? I actually added jquery (the WP bundled version) to the minify list as before </head> and blocking, and it seems to work in firefox and IE, but doesn't work in Chrome. Actually what happened for me was, I was using the jquery slider, and about 10-20% of the time on a page load the slider wouldn't appear. I turned on the javascript console in Chrome and noticed that jQuery is not recognized, almost as if there's a contention loading problem between the code that uses jQuery and jQuery itself.

    My slider enable code is surrounded by a jQuery(document).ready(function()) statement, so it shouldn't be loading before jquery finishes loading. However, that doesn't seem to be the case 10-20% of the time.

    For now, I'm removing jquery out of the minify settings, but wanted to see if anyone can make any recommendations.

    Thanks,
    Dustin

  2. Frederick Townes
    Member
    Posted 3 years ago #

    Do not use any of the additional optimization settings for JS minfication when using jQuery and it should work fine.

  3. impervious
    Member
    Posted 2 years ago #

    Fancybox (jQuery lightbox) won't work on my site at all with JS minification, even without using any additional optimization settings as you suggest.

    No biggie, I just won't use JS minification. ;-)

    Just FYI

  4. nemoprofeta
    Member
    Posted 2 years ago #

    I also have problems with jquery.
    I use the plugin Frontpage Slider, whici is based on jquery and if I enable js minification the slider is not rendered.
    I added the jquery-ui-interactions.js and jquery-ui-interactions.js to the "Never minify the following pages:" box but to no avail, the other js minifying options are set to the default: first three only enabled.
    If I disable js minification it works, how can I have it enabled?

  5. nemoprofeta
    Member
    Posted 2 years ago #

    I manged to work this out.
    In the minify settings tab, there is an HTML minification section. The second option reads "Inline CSS minification". If you enable it, frontpage slideshow doesn't render.
    I initially thought the problem was due to jquery files minification but I was wrong. Unticking the above option allows you to minify frontpage slideshow jquery files withouth problems.
    It could be a problem related to other uses of jquery, since often jquery code scans for css classes and then renders them.
    Hope this helps.

    By the way, Frederick, let me thank you, for this awesome plugin, its customizability allowed me to easily make my site really, really faster. The improvement can be seen with your own eyes, you don't even need to use performance measurement sites. I particularly love the minification help. It really made the difference. Thank you again, keep up the good work.

  6. impervious
    Member
    Posted 2 years ago #

    I want to echo what nemoprofeta said, W3TC has made HUGE and visibly apparent difference in my site speed. I'm using everything except JS minification, CloudFlare, Varnish and CDN, and I'm really happy with the speed improvement I'm seeing.

    I'll report back if I can get the jQuery to work with JS minification.

Topic Closed

This topic has been closed to new replies.

About this Topic