WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] It appears Page Cache URL rewriting is not working/ (10 posts)

  1. Matt
    Member
    Posted 2 years ago #

    I'm using W3TC version 0.9.2.4 on a site hosted on HostGator and keep getting this error:

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I have reset it to default settings, manually entered in the .htaccess entries, etc. Not matter what I do, this error won't go away. When I use Disk:Basic, everything works fine. When I use debug mode, it confirms that when Disk:Enhanced mode is used, there is no cache.

    Engine: disk: enhanced
    Cache key: _index.html_gzip
    Caching: enabled
    Status: not cached

    Anything else to check?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Matt
    Member
    Posted 2 years ago #

    Not sure why, but when I enabled BulletProof Security and added in the W3TC rules to the new .htaccess file, Disk:Enhanced started working fine.

  3. Matt
    Member
    Posted 2 years ago #

    Noticed that Disk:Enhanced is not throwing any errors, so it thinks it is working. However, when I enable debugging and look at the bottom of a page's source, I see:

    <!-- W3 Total Cache: Page cache debug info:
    Engine: disk: enhanced
    Cache key: _index.html_gzip
    Caching: enabled
    Status: not cached

    It is doing this for all pages that should already be cached. I visit a couple of times, but still nothing. When I look at my webserver, I see what appear to be the cached pages in /wp-content/w3tc/pgcache.

  4. AdrianRamiro
    Member
    Posted 1 year ago #

    Disable all debug flags, it's a bug from W3TC.
    Then you can check on cache folder that both _index.html and _index.html_gzip get created, so cache is working fine.

  5. sleenmg
    Member
    Posted 1 year ago #

    May sound crazy, but how do I disable all debug flags?

  6. AdrianRamiro
    Member
    Posted 1 year ago #

    @sleenmg on WP admin panel go to Performance -> General Settings
    On page footer you'll see Debug options, uncheck them all

  7. sleenmg
    Member
    Posted 1 year ago #

    Thanks. They actually are uncheckjed but that didn't remove the message. That's why I thought there was something else. I did switch from Super Cache if that has anything to do with it.

  8. CouponCodePlugin
    Member
    Posted 1 year ago #

    I have seen many of these errors which are mostly for minify, but sometimes for page cache. I have found a lot of times that it is incorrect, but you should check the debug output so that you can see what is really going on and identify any issues.
    If you are getting the same error as Matt, it is likely due to the .htaccess not being writeable.

  9. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Unfortunately, this is a common error, already addressed in the next release. Typically it's caused by permissions issues. If someone still wants help, please submit a bug submission form from the support tab of the plugin.

  10. CouponCodePlugin
    Member
    Posted 1 year ago #

    Thanks, its not too much of an issue. I can ignore it once I know it is working correctly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic