WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Issue with Media Library export (7 posts)

  1. bywave
    Member
    Posted 2 years ago #

    Hey Guys,

    I'm having an issue with the media Library export function, all the other CDN upload functions..eg. upload theme files, all work fine.

    However the media library export does not make any progress.

    I'm uploading to rackspace cloud.

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. bywave
    Member
    Posted 2 years ago #

    This is my output, do I need the bold item?

    Server Modules & Resources:

    Plugin Version: 0.9.2.4
    PHP Version: 5.3.10 (PHP5 required for Minify, Rackspace CloudFiles, Microsoft Azure support)
    Web Server: Apache
    FTP functions: Installed (required for Self-hosted (FTP) CDN support)
    Multibyte String support: Installed (required for Rackspace Cloud Files support)
    cURL extension: Installed (required for Amazon S3, Amazon CloudFront, Rackspace CloudFiles support)
    zlib extension: Installed (required for compression support)
    Opcode cache: Installed (XCache)
    Memcache extension: Not installed
    HTML Tidy extension: Installed (required for HTML Tidy minifier suppport)
    Mime type detection: Not installed (required for CDN support)
    Hash function: Installed (hash) (required for NetDNA purge support)
    Safe mode: Off
    Open basedir: Off
    zlib output compression: Off
    set_time_limit: Available
    mod_deflate: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_env: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_expires: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_headers: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_mime: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_rewrite: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    mod_setenvif: Not detected (required for Page Cache (enhanced mode) and Browser Cache)
    WordPress Resources

    /home/stabtemp/public_html/.htaccess: OK
    /home/stabtemp/public_html/wp-content: OK
    /home/stabtemp/public_html/wp-content/uploads/2012/02: OK
    Fancy permalinks: /%postname%/
    WP_CACHE define: Defined (true)
    URL rewrite: Enabled
    Network mode: No

  3. bywave
    Member
    Posted 2 years ago #

    Sorry to nudge this, but guys any help??

  4. Frederick Townes
    Member
    Plugin Author

    Posted 2 years ago #

    You need to have Fileinfo or mime_content_type apache modules installed for proper CDN functionality. Please check with your web host to see if either is available.

  5. cknowles
    Member
    Posted 2 years ago #

    I am also having this problem.

    I'm using Rackspace Cloud Files, and have successfully exported everything except my media library.

    When I try to export my media library the process only takes 19 seconds, the progress bar ticks up and finishes at 101%, reporting that 900 of 891 files have been uploaded, however, looking at my container on Rackspace, the files have definitely not been uploaded.

    I have installed Fileinfo and phpinfo() confirms this.

    Frederick I have submitted a bug report via the Support tab.

  6. cknowles
    Member
    Posted 2 years ago #

    Furthermore, not sure why I've only just noticed this, there are 10,980 images in my media library, not 891 - where is the plugin getting the number 891 from?

  7. cknowles
    Member
    Posted 2 years ago #

    Hi Frederick,

    Please disregard my posts, after running the SQL queries for the export_library & get_attachments_count functions in CdnAdmin.php against my database I have located the source of the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic